Jump to content

Archived

This topic is now archived and is closed to further replies.

Gavin_

Staging and Production licence issue

Recommended Posts

Gavin_

I have a staging site on staging.domain.com and a production site on domain.com
I activated the licence on staging and now I am being asked to activate another licence on domain.com
I have refreshed my account but it still wants me to go pro. 

Is this right? 
 

Share this post


Link to post
Share on other sites
Jackey

Have the same issue here. I need to stage in a subdomain, so I can make PL5 play nice with WPML.

I can't stage in a sub folder like I did before, because I need to install WP in the root of the domain and all languages in a sub folder,  so PL5 will render file URL's correctly.

Share this post


Link to post
Share on other sites
Jackey

@Simon Is this a service open to all subscribers... I might have the need for it when I run out of licences.

Share this post


Link to post
Share on other sites
Simon

We will be enabling some sort of client developer 'handoff' system in the future.

Yes if you want to unlink a test domain email the desk preferably with your username and domain to unlink.

localhost is always free

Share this post


Link to post
Share on other sites
Jackey
1 minute ago, Simon said:

We will be enabling some sort of client developer 'handoff' system in the future.

Yes if you want to unlink a test domain email the desk preferably with your username and domain to unlink.

localhost is always free

Yeah, localhost is nice if you have only one site to stage. :(

Share this post


Link to post
Share on other sites
Simon

i have about a 100 sites on localhost... 

Share this post


Link to post
Share on other sites
Jackey

Explained why...

Share this post


Link to post
Share on other sites
Jackey

No, but I already have it set up like that with MAMP, except I attached a subdomain as well so customers can peek in. ( so that consumes the licence :( ) Thanks for the info.

Share this post


Link to post
Share on other sites
Jackey

@Simon So xip.io should also work, so I can access the site with iPhone, iPad etc. from the local LAN.

Share this post


Link to post
Share on other sites
Simon

It depends how you have the hosts setup.

it checks the IP is 127.0.0.1 to determine if localhost.

Share this post


Link to post
Share on other sites
Jackey

Okay, so no... It resolves in the local ip of the machine running mamp.

Share this post


Link to post
Share on other sites
Simon

yea, and that should be 127.0.0.1

if not, why not? are you running mamp on a server or something"?

Share this post


Link to post
Share on other sites
Jackey

Yeah, a mac mini... Did that so I can test my pages on windows, macs and ios devices... the client access was a convenient bonus.

Share this post


Link to post
Share on other sites

×