Jump to content

Archived

This topic is now archived and is closed to further replies.

Danny

Compatible Plugins/Themes

Recommended Posts

Danny

Hello, everyone.

I am currently writing documentation for compatible themes and plugins. Thus far I have included some popular themes/plugins that are used my most WordPress users. However, I need your help, as I can not test all these plugins or themes.

Compatible Plugins: http://www.pagelines.com/resources/compatible-plugins/
Compatible Themes: http://www.pagelines.com/resources/compatible-themes/

So if you find any popular plugin or theme missing from the articles link above. Please, reply to this topic in the following format:

Plugin/Themes Name: 

Link to Plugin/Theme: 

How you have tested the Plugin/Theme:

Any complications i.e. bug(s), glitch(es) that we need to be aware of:

Why you use that particular Plugin/Theme: 

If a premium Plugin/Theme, please email me ([email protected]) with a zip of said plugin/theme and a link to your reply on this topic.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JudithKlinger

Shortcodes Ultimate only works sometimes (example: pullquotes does not work, heading does work)

Share this post


Link to post
Share on other sites
Simon
49 minutes ago, JudithKlinger said:

Shortcodes Ultimate only works sometimes (example: pullquotes does not work, heading does work)

That's because of a known bug .. The CSS does not get queued into the footer that is generated by the shortcode

Share this post


Link to post
Share on other sites
James Giroux

Hey Danny,

I tested P5 out with Sage starter theme (roots.io).  I tested it along with several other common page builders and P5 did not load on the front-end.  My guess is that this is related to how Sage uses their theme wrapper to build pages rather than traditional template files.  The plugin itself loaded without any issues, everything on the back end worked as expected but when you flip to the front-end and try to turn on the page builder, you get some spinning wrenches and nothing ever loads.  This was a few weeks ago so if there's been a major update, it might be resolved but I'd encourage you to test it out for yourself.  

James.


James Giroux, CEO
Groundwork

Share this post


Link to post
Share on other sites
JudithKlinger
4 hours ago, Simon said:

That's because of a known bug .. The CSS does not get queued into the footer that is generated by the shortcode

Is there a fix? 

Share this post


Link to post
Share on other sites
Simon

It will be fixed before release.

Share this post


Link to post
Share on other sites
JudithKlinger
2 minutes ago, Simon said:

It will be fixed before release.

Ok. I need something now, so will figure out some sort of workaround. Thanks.

Share this post


Link to post
Share on other sites
Danny
17 hours ago, James Giroux said:

Hey Danny,

I tested P5 out with Sage starter theme (roots.io).  I tested it along with several other common page builders and P5 did not load on the front-end.  My guess is that this is related to how Sage uses their theme wrapper to build pages rather than traditional template files.  The plugin itself loaded without any issues, everything on the back end worked as expected but when you flip to the front-end and try to turn on the page builder, you get some spinning wrenches and nothing ever loads.  This was a few weeks ago so if there's been a major update, it might be resolved but I'd encourage you to test it out for yourself.  

James.

Hi, James.

Can you provide a link to the several themes you test please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Hi @Danny Just wanted to report that CSS Hero is not yet (fully) compatible with PL5. You have to activate a experimental feature named 'Rocket Mode' which they build to support themes that don't natively support CSS Hero. With this mode enabled you can change some items but CH is not yet fully able to differentiate between various elements. As reported by @Jackey in another post. I've tried it with DMS2 and that works rather well. Some additional code needs to be added to PL5 to support it native but @Andrew Will be probably aware of that since DMS2 works. Would love to see this become compatible. For more info: http://www.csshero.org/developers/

 

Share this post


Link to post
Share on other sites
wendygordon

Would love to know if anyone has tested:  Envira, Huge-It Portfolio, or Special Related Posts? and an events manager plug in?

Share this post


Link to post
Share on other sites
Skip

Danny

I appreciate your work on this...  I have an idea!

How about Platform 5 being compatible with Pagelines Themes - specifically DMS...

Share this post


Link to post
Share on other sites
Skip

Danny

Another idea about plugins...

How about Platform 5 being compatible with every plugin and theme that Pagelines has sold on their website in the past...

Share this post


Link to post
Share on other sites
onespirit

I have to applaud that suggestion @Skip!

It seems totally reasonable to me that if Platform 5 is meant to be compatible with as many themes and plugins out in the WordPress world that it would first be compatible with Pagelines products.

I realize this may not be possible in all cases but it would it would make allot of people very happy having purchased many of those plugins, sections and themes that may be now useless on a PL5 install.

Personally I'd love to be able to convert all my DMS sites to PL5 right now because it's so blazing fast on both front and backend compared to DMS2.

But it's not quite there yet. I would need things like poppy, i-slider, i-header, PL next box. The fact is I can't  completely recreate my current DMS designs 100% yet with PL5.

Once I can though you can be sure I'll be converting. I'm enjoying PL5 quite allot! Great work guys!

 

Share this post


Link to post
Share on other sites
jamieg270

Hi Danny,

WP-LESS doesn't seem to work with Platform5 nicely. I was hoping to use it for LESS support in my child theme. To be fair it may be my unfamiliarity with the plugin or some kind of error with my implementation. I'll play around with it and see if I can find the issue. 

Using the method they advise to enqueue the LESS files causes the Platform5 interface to load indefinitely at the moment, however any other method doesn't compiled the LESS... 

Share this post


Link to post
Share on other sites
Simon

Why do you need wpless? There is a less plugin for pl5

Share this post


Link to post
Share on other sites
jamieg270

Does that plugin allow you to use and compile LESS files in the child theme or do you have to enter the LESS in an admin panel? I've not installed that plugin yet and was using Platform5 on a test install that happened to have WP-LESS already installed on it as I was evaluating it, and already set to use less stylesheets in the child theme. Not a huge issue, just something I noticed...

Could be an issue with a existing site that uses it that someone then installs Platform5 on I guess.

Share this post


Link to post
Share on other sites
jamieg270

Hi Danny,

I installed the Platform5 LESS plugin. That might be useful for specific code for a specific site and for small amounts of it. However I am developing a base child theme that I was intedning to use for all future sites, there are some common elements I would like to set within that base theme in a .less file (which is how I work in DMS) which I was hoping to use WP-LESS to compile so I don't have to re input it every time. I can also see on some complex sites that LESS panel getting very difficult to navigate if you happen to have a lot of code in there.

I'm also much more comfortable using my general code editor (Coda) and keeping a core file/s for elements so I can easily reuse code and keep track of changes to those common elements. I can't really do that when the LESS is entered into a field in the front end...

Share this post


Link to post
Share on other sites
Simon

 

On 12/3/2015, 12:22:27, jamieg270 said:

Hi Danny,

WP-LESS doesn't seem to work with Platform5 nicely. I was hoping to use it for LESS support in my child theme. To be fair it may be my unfamiliarity with the plugin or some kind of error with my implementation. I'll play around with it and see if I can find the issue. 

Using the method they advise to enqueue the LESS files causes the Platform5 interface to load indefinitely at the moment, however any other method doesn't compiled the LESS... 

What part of WP-LESS isnt working? I just tested it and it does exactly as advertised.

What code are you using to load the stylesheets?

Share this post


Link to post
Share on other sites
jamieg270
6 minutes ago, Simon said:

 

What part of WP-LESS isnt working? I just tested it and it does exactly as advertised.

What code are you using to load the stylesheets?

The LESS files weren't compiling and the front end became unresponsive. The editor just had the cog going around indefinitely. The child theme was based on the pagelines.com child theme. I was doing all this in MAMP/localhost so it may be to do with my development environment. 

I used the code below to register the stylesheet:

add_action('init', 'theme_enqueue_styles');

function theme_enqueue_styles() {
    wp_enqueue_style('pwm-main', get_stylesheet_directory_uri().'/less/pwm-main.less');
}

And added the following line to the config file so it would always recompiled while in development:

define('WP_LESS_ALWAYS_RECOMPILE', 'true');

 

Share this post


Link to post
Share on other sites
jamieg270

Thanks I'll retry when I get a chance with the correct action.

Share this post


Link to post
Share on other sites
larrojas

Hi there,

I am using KLEO theme, with multisite, buddypress and bbpress. 

KLEO theme page:   http://seventhqueen.com/themes/kleo/

this is my site..http://rojasspanish.com/

it seemed that KLEO and Platform 5 were working good but I noticed then that the function to cop the profile picture on buddypress fails, on the "Change profile photo".

I thought it was a conflict with plugins. I tested them all and nothing, until deactivated platform 5, and it works. See pic. 

noupload01.JPG

http://rojasspanish.com/media/noupload02.JPG 

 

noupload03.JPG

 

Any help here?

Thanks,

 

 

 

 

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • petere21
      By petere21+
      After activate new web site
      I had several licences for use but system show me that I have no licence 
    • petere21
      By petere21+
      When i see wp content,i have no margin from left and right side means bordee on tablet view
      mobile margin around wpcontent is fine dtp also ok it looks like spread enough  on tablet - ipad - there is no margin and text from left side and widgets from tight side content sticking border of monitor how could i fix margin for example 5px for tablet view? But without changing the mobile margin 
      Sample https://www.restartnisa.sk/poloniny-po-zemplinsky/
      thanks 
      petere
    • petere21
      By petere21+
      Does pagelines support AMP technology for mobiles?
       
    • petere21
      By petere21+
      How to control spaces between images ?
      I can control section  padding from left and right side but not between  images.
      Could someone help me?
    • petere21
      By petere21+
      After changing protocol http to https I have lost all count information next to the icon in the Sharebar extension. All counts is set to zero. Is there any chance to give number of sharing take back? 
      thanks
×