Jump to content

Archived

This topic is now archived and is closed to further replies.

robwahl

[Solved] Salebar on iPad in Safari on Privacy Mode

Recommended Posts

robwahl

Hi there,

I know this has been discussed in the past, but will you guys be fixing the bug that causes web pages to display incorrectly when the Salebar is activated and it is being viewed on an iPad in Sarafi in privacy mode?  My DMS2-built website displays correctly on my iPad 2 always when the Salebar is turned off, or if the Salebar is on, then only when not in Privacy mode.  If the Salebar is on and Safari's Privacy mode is enabled, entire sections of the site disappear.  I can post images to illustrate if needed...let me know.

This is pretty concerning, as I'm sure many people browse using Safari in Privacy Mode on an iPad, and I like to use the Salebar.  I'm spending money on Facebook and Google advertising at the moment, and hate the idea that my site won't display properly for a lot of people who visit.  I'm not sure if the problem is isolated to the iPad 2...I don't have a newer iPad to test with.  Both the OS and Safari are up-to-date on my iPad.

Thanks.

Share this post


Link to post
Share on other sites
Simon

Can you give us a URL to test. I have the ipad emulator here with xcode and it has a setting for ipad2.. but i dont see a setting anywhere for safari privacy mode?

Share this post


Link to post
Share on other sites
robwahl

Thanks Simon.  Not sure about where a privacy mode setting would be on your emulator.  My site currently has Salebar enabled. Please find attached 2 screenshots - one taken in normal browsing and one seconds later with privacy mode enabled, both in Safari on my iPad 2.  Several sections just fail to appear with privacy on (you'll notice the image is missing in the screenshot, but there are several other sections below that image, including the footer, that don't appear with privacy on).  Note that with Salebar off, my site appears perfectly normally when viewed with privacy mode enabled on the iPad, so this is definitely related to Salebar.  I'm not the one who discovered this; I read about the issue somewhere else on this forum and realized that is why I was having the same problem.  My site is www.symbolslearning.com.

Again, this could very well be an issue on all iPads, not just the iPad 2.  I just don't have access to other iPads to test it.  Thanks again.

IMG_0210.PNG

IMG_0211.PNG

Share this post


Link to post
Share on other sites
robwahl

I should also mention that in addition to the missing sections, the menu also doesn't work in privacy mode.

I was wrong about the footer...the footer actually does appear after a lot of scrolling.  But the logo and social icons at the top, the slider and the testimonials sections all don't appear.  The iBoxes appear but don't fully load.

Share this post


Link to post
Share on other sites
Simon

its a javascript error, in privacy mode salebar does not have access to localstorage.

Share this post


Link to post
Share on other sites
robwahl

OK, thanks...so what does that mean?  Can this be fixed?

Share this post


Link to post
Share on other sites
Simon

yea it can be fixed.

Share this post


Link to post
Share on other sites
robwahl

Amazing!  that's great news, as I love using Salebar but hate the idea that some visitors can't properly see my site.  I have Pagelines Updater installed...I'm guessing that if/when Salebar is updated I'll get some kind of notification?  Thanks again Simon.

 

Share this post


Link to post
Share on other sites
Simon

Yea im just working a fix now.. 

Share this post


Link to post
Share on other sites
Simon

ok 2.0.3 is live.. you can bypass the boring update wait by downloading the version form your account area. 

Share this post


Link to post
Share on other sites
robwahl

I installed the update and can confirm that the fix worked! Thanks very much Simon.  Very glad this is resolved.

Share this post


Link to post
Share on other sites
Danny

This topic has been marked as solved and therefore closed.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×