Jump to content

Archived

This topic is now archived and is closed to further replies.

dawsonbarber

Possible Conflict with Yoast SEO

Recommended Posts

dawsonbarber

I've been playing with PL5 on a couple of different installations under development and have run into a problem on one installation where the menu appears at the bottom of the page (and the menu is in the header section in the builder).

In fact everything within 

<div id="site" class="site-wrap"></div>

gets pushed to the bottom of the page.

I deactivated everything and the menu appeared where it should (at the top). I reactivated one by one and found that the problem returned after reactivating Yoast SEO.

 

Share this post


Link to post
Share on other sites
dawsonbarber

I tested it on the other installation and there's no problem.

Everything's up to date on both sites and both are running all of the same plugins (but, as mentioned, I did deactivate all of them to isolate Yoast as the problem).

The site with the problem is a Multi Site installation. Do you think that could have something to do with this?

(Site's on maintenance mode, otherwise I'd post the URL).

Share this post


Link to post
Share on other sites
dawsonbarber

The "problem" wasn't a problem.

I deactivated/removed multi site and still had the apparent conflict with Yoast SEO.

I decided to start the installation from scratch - I'd been mucking around on it for over a year so there was some baggage - and the nav displays as it should with Yoast active on the site.

Share this post


Link to post
Share on other sites
martinjrob

I had the same issue with a site i built with the old pagelines framework a couple of years ago, i installed pl5 onto the site and the header was showing in the footer area and the footer in the header, i was and am still using yoast seo.

I decided to do a clean install with pl5 and everything looks and works ok so far.

Share this post


Link to post
Share on other sites
janpeeters

I had sort of the same problem when I moved the database of a DMS2 install to a new install to rebuild my site with PL5. With Yoast SEO activated the menu was not at the top of the page. but also not in the footer. I saw all the items that should be body content above the menu. With Yoast SEO deactivated it jumped to the top. I decides to reset Yoasts settings and that fixed it. So I guess there must be an issue with Yoast SEO but the question is if it can be tackled. Bit of a vague problem.

Share this post


Link to post
Share on other sites

  • Similar Content

    • medtime
      By medtime+
      Hello,
      We are using ProPricing but We cant change the colors from the Table. 
      How can we change it? It is all grey and we would like to add colors according our identity.
      Best,
       

    • ppotent
      By ppotent+
      Any chance of a pagelines table plug-in coming? I know that the use of short codes and bootstrap can achieve this, but I can't seem to find any easy/visual editor way of doing this. There are table plug-ins around for wordpress, but honestly, they are pretty clunky. I'd pay for a tables plug-in, given how much I would use tables if I could.
       
       
    • Jeffrey Salim
      By Jeffrey Salim+
      When trying to activate the Facebook Plugin, using the Bootstrap Theme under Platform 5, the following Fatal Error occurs:
      Parse error: syntax error, unexpected '[', expecting ')' in /wp-content/plugins/pl-plugin-login-facebook/libs/fblogin.php on line 35
      If anyone has any advice, it would be greatly appreciated...
    • Queue-it
      By Queue-it+
      Hi,
      We're using Yoast SEO plugin and it can not crawl the content that is in a Pagelines text container, only the Paglines framework content. 
      I can see that it is a problem with SEO plugins and external site builders to read the content. So is there a Pagelines SEO plugin that would solve that? 
      I know that it does not effect stats on google, but it is not possible to see the full picture of SEO status. 

    • Thijs
      By Thijs+
      Hi,
      I am using the plugin WP-Property with an addon called "WP Property Supermap".
      Testwise I've added the shordcode [supermap] to
      the post loop a embed section a text section The supermap is located as third after the H1 and H2 tags but the map gets displayed at the top of the page, 
      All three ways break up the page structure of all content which is above the supermap.
      My question is: Where is the error?  Is it the plugin or the theme which causes the display errors?
×