Jump to content

Archived

This topic is now archived and is closed to further replies.

Inbound Horizons Inc.

Fixed Header Content Wipes When Updating Page That The Content Is Hidden On

Recommended Posts

Inbound Horizons Inc.

I am using the canvas area feature in the header for 'Hide on specific pages or posts' with page IDs for the pages I do NOT want this instance of the header menu to show on. Let's say I have 6 pages on the site where I want to hide this otherwise site-wide menu header on; I am also hiding the entire canvas area in the header, not just one element but an Ubermenu and some text boxes with logo, buttons, etc... On any of those 6 pages the header section rightly responds in DMS view with the "Canvas area returned no output" message once I have put in the ID to hide the header canvas area on the page. BUT if I make a change to one of those 6 pages that has the header canvas area hidden, then publish it after clearing the LESS/CSS caches, the other pages where the content is NOT hidden show the header region as blank/empty now as well. Prior to that the areas hidden on those other 6 pages showed fine in the header area across the site, but now are wiped out globally. Interestingly the now-blank header canvas area still retains the correct comma seperated values for page IDs in the 'Hide on specific pages/posts' text input area, so I know that the canvas area itself is not getting wiped, but all of the elements within it are. 

Could it possibly be that when publishing changes on a page in DMS that has a hidden content area, DMS recognizes the container holding the hidden content (in this case the header canvas area) to update it along with the other page elements, but reads it as empty since content is not displayed, then writes to the DB that the container is empty of elements, thus causing the issue globally on the other pages? I have not been able to replicate this when updating content via DMS on pages that have the header content showing, but on pages with the header content hidden it has happened every time. Perhaps putting a conditional in the DMS update loop to exclude updating an element or canvas area that is supposed to be hidden on that page, thus avoiding wiping the content with the empty canvas area/element, would fix the issue. Don't want to start digging into DMS core though as you all know your software much better than I do!

I am assuming this is something  others in the PL/DMS community are also experiencing so would be glad to see it resolved. On my install I am using the latest version of DMS and WP 4.3 but the issue had also happened on earlier versions of both. Please note also that turning off all the plugins has not affected or resolved the issue in the past;

Share this post


Link to post
Share on other sites
batman

Hi

The URL is this http://www.sanantoniomobilehomes.com

Please, you can say me what version of DMS are you using and if you are using a child theme to write your CSS.

 


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Inbound Horizons Inc.

Hi, no the URL for the affected site is actually http://www.alamohomes.net and as an example, the header section on the front main page is hidden, but on the category/post pages it is not hidden. It's running on DMS 2.2 but uses a child theme; 

Share this post


Link to post
Share on other sites
Inbound Horizons Inc.

Anybody have any ideas on this one? Problem is not resolved; thanks!

Share this post


Link to post
Share on other sites
Danny

Hi,

I have viewed your site and your logo navigation repeats itself three times. You also have an active cache plugin, please flush the cache via the cache settings and then disable it. As we can not provide support to users who have active cache plugins.

In regards to your header issue, can you provide screenshots of what you current have configured to hide your header region please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×