Jump to content

Archived

This topic is now archived and is closed to further replies.

jeomiland

alternate social icons, SSL/non-SSL mixed errors w/social and shoppingcart

Recommended Posts

jeomiland

In post 34871-sharebar-issues Danny suggests one can use any of the icons in font-awsome for social share icons. What's the best way to use other images?  Client asked me to implement the icons at http://www.wpbeginner.com/showcase/16-best-free-social-media-icon-sets-for-wordpress/  specifically #20 "20 Social Media Icons". Have downloaded the zip file containing those icons but where/how get them to show up on the site?

So I am referring to both the icons to send visitors to the site owner social properties AND shar icons so people can Like, share ect.

Upon further research, I see a discussion on problems with using social icons on SSL (https://...) sites since a warning message comes up complaining about mixed SSL and non-SSL content on the page? Since this site is a shoppingcart site, using Woocommerce, this could be a problem. What's the current wisdom on dealing with this?  Also, I read a while ago there can be a performance hit if one makes their whole site SSL, so since Wordpress and themes adds significant overhead, what's the current wisdom on this issue?  SSL for all pages or just for shoppingcart checkout/account info pages?

Thanks

site: http://verdanthomeproducts.com
 

Share this post


Link to post
Share on other sites
Simon

SSL does not add overhead, in fact google ranks sites higher that are SSL.

 

Share this post


Link to post
Share on other sites
jeomiland

Hi Simon

Thanks so much for your quick reply! What say you about the "mixed secure/non-secure types on page" error msg? This was discussed in "How do I get Sharebar social media icons to be HTTPS secure?" March 16, 2014 and James B said "the url's for the buttons in that section is hardcoded..." has this been resolved now in the latest DMS?  Have not yet purchased the Rapid SSL and installed it but will have to pronto.

Thanks

Share this post


Link to post
Share on other sites
Simon

That old post refers to DMS1.

The sharebar in DMS2 gets its data from facebook or wherever using protocol relative urls //facebool.com for example, which works in ssl and non-ssl

Share this post


Link to post
Share on other sites

  • Similar Content

    • greatthingsllc
      By greatthingsllc+
      Recently I noticed that the Social Share count were reset to zero across several sites I manage.   Some had very high numbers that some clients liked to see.   Can this be refreshed to get the old counts back?
    • MissT
      By MissT+
      The social icons within the Sitemap Footer section plugin are not longer showing on screen. Site details will be sent via email separately.
      WordPress - 4.7.2
      Pagelines Framework Version 5.0.97
      Platform 5 Version - 5.1.6
      Section Sitemap Footer version - 5.0.4.
       
      All other plugins deactivated.
    • pieterbartlema
      By pieterbartlema
      Dear All,
      Somehow the the social icons went missing in the site branding section. please help...
      www.buscafins.com
    • jeomiland
      By jeomiland+
      Hi guys
      I recently was asked by client to make a Woocomerce site I'm working on be able to display in Spanish. After some research I found transposh plugin had good reviews. So installed it. Put the widget in DMS2 sidebar and set it up for just English and Spanish, with english default. When I checked the site, it would not display spanish when chosen, but it did start to display " " in several places. So I turned it off again.
      Contacted Woocomerce who replied:
      So I deactivated the plugin, but now stuff is showing up in spanish in the dashboard (like Activate/update/delete under plugin names, field text in Gravity forms and probably lots of other places I haven't checked out yet but the main site content looks english!?!?!
      So I turned transposh back on but this is a problem... can't have a plugin active that is causing clashes, so where do I look to reset the system base language back to english when the plugin is deactive?
      Thanks
      oh, site is at http://ecoluxhomeproducts.com/storedev/  (in english now, but transposh active...)
    • abuzzelli
      By abuzzelli+
      Trying to display social icons in the footer of http://brkichdesign.com/NewSite/. All are working but yelp. It's right after the pinterest icon, it's there but not showing up. Any ideas why?
×