Jump to content

Archived

This topic is now archived and is closed to further replies.

nadielp

Multimenu text color

Recommended Posts

nadielp

Hi Everyone,

Problem with multimenu on a site http://owltalk.com/new/. So I have the text set to be black on a white background...simple enough. When one clicks the hamburger the text is white on a white background. If I set the header and background setting to a color one can see the white text. I have not invoked white text anywhere on this site so I am a little puzzled. Any help with this problem would be greatly appreciated.

 

Thanks,

Daniel

Share this post


Link to post
Share on other sites
Danny

Hi Daniel,

Can you take a screenshot of your MultiMenu options, so I can see how you have configured it please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nadielp

Hi Danny,

I have the background set to  color just so the white text appears since I can't seem to get it to show in black. But you can see I have the background theme set to a white background/black text option. 

Here it is: https://www.dropbox.com/s/1d16ra2c9etnb9l/Screen-Shot-2015-09-01-at-8.33.38-AM.jpg?dl=0

Here is a link to a screenshot of the global color settings as well: https://www.dropbox.com/s/xumtojkljt9keim/Screen-Shot-2015-09-01-at-9.26.26-AM.jpg?dl=0

 

Thanks!

Share this post


Link to post
Share on other sites
nadielp

Hi Danny,

Just following up on this. Thanks!

Share this post


Link to post
Share on other sites
Danny

Can you enable the option again, as your site is now using a different multimenu option so I am unable to diagnose the issue properly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nadielp

Hi Danny,

 

Apologies for that...I have set it back to the hamburger style...mind you I have it set for black text and it is displaying white text...that is why I have a background at the moment...so people can read the items.

 

Thanks!

Share this post


Link to post
Share on other sites
Danny

In options screenshot, you have one of the options set to #F3F2F2, have you now changed this to #F1EEEE ?

If so, the color is coming from the color you set in that option. The Background theme option will not affect the background color of the slider/mobile menu. You will want to either change your color setting to something darker or use the following CSS:

.section-multimenu .levelHolderClass {
  background-color: #000;
}

You can replace #000 with anything you like.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nadielp

Hi Danny,

 

We have a misunderstanding. I want the text to be black. I only have a background color so the white text can be seen...since the site is live. No matter what settings I choose the text always remains white for the hamburger menu. So what I need is a bit of code to override the white text problem.

Thanks and sorry for the confusion on this...

Share this post


Link to post
Share on other sites
Danny

Add the following to your custom CSS:

.section-multimenu .multimenu-wrapper ul li a {
    color: #000;
}
.section-multimenu .multimenu-wrapper ul li a:hover {
    color: #F00;
}

This will give you black text on the MultiMenu and red when hover over the items. You can replace the red color value in the code to whatever you like.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nadielp

Hi Danny,

Thanks that solved the text issue except for getting the "x" to close the menu. The "x" is still in white text. Sorry.

Share this post


Link to post
Share on other sites

  • Similar Content

    • jaithai
      By jaithai+
      Unable to attach an image that's already been uploaded.
      When attempting to upload one from scratch, it gives me the error seen in the screenshot. As you can see by the Chrome Inspector, I receive a 400 error.
       

    • stijnxo
      By stijnxo+
      Ik like to use the following Plug-in in my DMS Theme, but can' get it to work. My DMS Editor is not loading anymore if I paste this short code in a page, textbox or mediabox: [wpdatatable id=1]
      Plug-in: WPDataTables Plug-in 
      Shortcode:  [wpdatatable id=1]
      Website: http://gentleclinics.nl/prijslijst-heren/

      Anyone experience with this plug-in and DMS.
    • foxwatson
      By foxwatson+
      I recently downloaded the latest DMS2 update. Since the download, I lost front end ability to update. Any suggestions would be appreciated.  
    • Justin Taylor
      By Justin Taylor
      I originally purchased, I believe, a 3 site licence for DMS2. The new account interface does not reveal any of this information.
      How do I know how many licences I am entitled to? How do I reset one for a new website? All it says now is that I don't have any Pro licences?
×