Jump to content

Archived

This topic is now archived and is closed to further replies.

antonyg

DMS Not Working Well, Changes Not Being Saved

Recommended Posts

antonyg

I am having difficulties today.... Have updated several sites to the latest WP version (4.3) and it seems after the update that the problems started occurring - checked some sites I had not yet updated and they're working fine. All running latest version of DMS.

First began having problems with components having a mind of their own, i.e. disappearing or moving by themselves. Then started mostly having problems with the media box - as soon as a media box is selected for editing nothing more can be done, i.e. changes to the media box will not save and then cannot edit another component - it is stuck on that media box. Logging out and back in sometimes works - until you click on edit a media box again.

Java console is reporting error "Uncaught TypeError: Cannot use 'in' operator to search for 'length' in" then lists a whole number of functions looking like their from jquery. 

Assistance is greatly appreciated. 

Regards

Antony

Share this post


Link to post
Share on other sites
Danny

Hi,

Can you provide a link to the site in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

I have the same problem, updated to 4.3 and any change that I make in the PL editor on e.g. sections doesn't stick when saving. Deleting or adding settings it's all the same. I'm going to try to revert to 4.2 for now. Thanks for having a look into this Danny. The site is http://lovo.nu (working on it as we speak). So might be back to 4.2 when you check.

Update: I've reverted. Downloaded the previous Wordpress 4.2.4 replaced all files in my FTP Wordpress install directory except wp-config.php and the folder wp-content. Wordpress asked me the update database afterwards, okayed that, and all is working fine now. I'll keep watching this thread to see when the problem has been determined. Might be the new editor.

 

Share this post


Link to post
Share on other sites
dreja

I'm having the same problem - nothing is saving. Janpeeters, I'm going to take your advice and revert back to the old version!

I have the same problem, updated to 4.3 and any change that I make in the PL editor on e.g. sections doesn't stick when saving. Deleting or adding settings it's all the same. I'm going to try to revert to 4.2 for now. Thanks for having a look into this Danny. The site is http://lovo.nu (working on it as we speak). So might be back to 4.2 when you check.

Update: I've reverted. Downloaded the previous Wordpress 4.2.4 replaced all files in my FTP Wordpress install directory except wp-config.php and the folder wp-content. Wordpress asked me the update database afterwards, okayed that, and all is working fine now. I'll keep watching this thread to see when the problem has been determined. Might be the new editor.

 

 

Share this post


Link to post
Share on other sites
Simon

There was a minor update to jQuery and it seems to have broken a few things that we overlooked.

As an emergency patch simply add this to your functions.php file...

/**
 * Fix uploader issues with DMS2 and WP 4.3 jQuery
 */
add_action( 'wp_enqueue_scripts', 'fix_jquery_for_dms' );
function fix_jquery_for_dms() {
	if( ! is_admin() && function_exists( 'pl_draft_mode' ) && pl_draft_mode() ){
		wp_deregister_script('jquery');
		wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.js"), false, '1.11.2');
		wp_enqueue_script('jquery');
	}
}

It will reregister jquery with the version before 4.3, perfectly safe and the patch only works while you have the editor open so it will not affect any other plugins.

Share this post


Link to post
Share on other sites
janpeeters

Thanks Simon, that works.

Applied the patch to my child-themes functions.php after updating to WP 4.3 and changes now stick. 

Jan

Share this post


Link to post
Share on other sites
Simon

Thanks Simon, that works.

Applied the patch to my child-themes functions.php after updating to WP 4.3 and changes now stick. 

Jan

Thanks for confirming Jan :)

Share this post


Link to post
Share on other sites
dreja

There was a minor update to jQuery and it seems to have broken a few things that we overlooked.

As an emergency patch simply add this to your functions.php file...

/**
 * Fix uploader issues with DMS2 and WP 4.3 jQuery
 */
add_action( 'wp_enqueue_scripts', 'fix_jquery_for_dms' );
function fix_jquery_for_dms() {
	if( ! is_admin() && function_exists( 'pl_draft_mode' ) && pl_draft_mode() ){
		wp_deregister_script('jquery');
		wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.js"), false, '1.11.2');
		wp_enqueue_script('jquery');
	}
}

It will reregister jquery with the version before 4.3, perfectly safe and the patch only works while you have the editor open so it will not affect any other plugins.

Thank you -- this worked a treat.

Share this post


Link to post
Share on other sites
BlueSkyCreative

There was a minor update to jQuery and it seems to have broken a few things that we overlooked.

As an emergency patch simply add this to your functions.php file...

/**
 * Fix uploader issues with DMS2 and WP 4.3 jQuery
 */
add_action( 'wp_enqueue_scripts', 'fix_jquery_for_dms' );
function fix_jquery_for_dms() {
	if( ! is_admin() && function_exists( 'pl_draft_mode' ) && pl_draft_mode() ){
		wp_deregister_script('jquery');
		wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.js"), false, '1.11.2');
		wp_enqueue_script('jquery');
	}
}

It will reregister jquery with the version before 4.3, perfectly safe and the patch only works while you have the editor open so it will not affect any other plugins.

Hi there, I might be being thick as not a major coder.....

 

I use the child theme and my function code is here...and I added the above fix but when I upload and try to go into the dms2 editor the spinner keeps spinning and then says there is an issue and wont load...

 

As you will see the code fix is at the bottom...please what am I doing wrong? Thanks

 

Paul

 

Share this post


Link to post
Share on other sites
Simon

remove your code, impossible to read pasted into a forum like that anyway, heres a plugin does the same thing: fix-dms2-jquery.zip

Share this post


Link to post
Share on other sites
BlueSkyCreative

remove your code, impossible to read pasted into a forum like that anyway, heres a plugin does the same thing: fix-dms2-jquery.zip

Hi there, Removed the code from functions and installed the plugin. I have tested it on two of my sites and both dms2 editors wont load. both have spinner opps info...

:(

Share this post


Link to post
Share on other sites
Simon

The plugin thows no errors, check the HTML source of the page for php errors, and the chrome console for javascript errors.

Share this post


Link to post
Share on other sites
BlueSkyCreative

The plugin thows no errors, check the HTML source of the page for php errors, and the chrome console for javascript errors.

Hi I have checked with the chrome console (after googling it lol) and there seems to be a conflict with Simply Scroll up which is a dms plugin 

(anonymous function) @ simply-scroll-up.js?ver=092ecd:1jQuery.Callbacks.fire @ jquery.js?ver=1.11.2:3143jQuery.Callbacks.self.fireWith @ jquery.js?ver=1.11.2:3255jQuery.extend.ready @ jquery.js?ver=1.11.2:3467completed @ jquery.js?ver=1.11.2:3498

 

when simply scroll up is deactivated the site now loads and the function issue I had now stick so all good...not sure what the issue is with simply scroll up but prob is the java issue

 

many thanks

 

 

Share this post


Link to post
Share on other sites
Simon

Cant be, the version in the error you quoted is 1.11.2, thats the good working version provided by the plugin/patch. 1.11.3 is the default (bad) version.

Problem could simply be the plugin is broken?

Share this post


Link to post
Share on other sites
rmalt

Perhaps in the future, Pagelines could alert people to the problem (and a solution) proactively.  I spent two hours this morning trying to figure out what I was doing wrong before coming to the forum looking for and finding a solution that took 1 minute to apply.

Share this post


Link to post
Share on other sites
Simon

Perhaps in the future, Pagelines could alert people to the problem (and a solution) proactively.  I spent two hours this morning trying to figure out what I was doing wrong before coming to the forum looking for and finding a solution that took 1 minute to apply.

Apologies for that, we are working on an update to DMS2.

Share this post


Link to post
Share on other sites
timtimhungerfordcom

any idea of when the update will be available

Share this post


Link to post
Share on other sites
Simon

Its already out. WordPress checks every 12 hours, keep checking back it'll be there eventually.

Share this post


Link to post
Share on other sites
evscicats

My site whitescreened when I applied the Pagelines update on my site.  I still have WP 4.2.4... waiting a few days for plugins and themes to push out updates before updating WP just in case.

I put the previous version of DMS back on via FTP.  

Share this post


Link to post
Share on other sites
antonyg

Just starting for the day (morning now here in Australia), read the posts and applied the DMS update which has worked 100%. Thank you guys for the support, so much appreciated. 

Regards

Antony 

Share this post


Link to post
Share on other sites
Justin Taylor

I just encountered all this. I was getting errors until I removed the code above from functions.php

I'm running the latest Wordpress with the latest DMS.

Share this post


Link to post
Share on other sites
timtimhungerfordcom

Any update on a fix for this? URGENT

Share this post


Link to post
Share on other sites
Simon

timtim what version are you using? what theme? child theme? what version of jquery is being loaded?

Share this post


Link to post
Share on other sites
timtimhungerfordcom

Thanks Simon in advance fro your help.

My URL: onetribefest.com

Wordpress: 4.3

DMS2Version: 2.1.9.3

Chrome: Version 44.0.2403.157 (64-bit)

Share this post


Link to post
Share on other sites
Simon

you should update the theme tim, you are quite a few versions behind, either using the updater or download the zip from your account area and upload via FTP

Share this post


Link to post
Share on other sites

×