Jump to content

Archived

This topic is now archived and is closed to further replies.

emilyf

Slide loading very slowly in Safari

Recommended Posts

emilyf

Our new Pagelines site has been up about a month (brianboggschairmakers.com) and so far it's worked fairly well. 

Reviewing our Google Analytics, however, has brought to my attention that the site is loading exceptionally slowly on Safari, both on mobile and desktop. Average load time for each page is 4-8 seconds, but on Safari, it's over 22 seconds!

Anybody else have this problem? Any recommendations?

 

Share this post


Link to post
Share on other sites
Simon

you have over 8MB of images on the front page, have you tried optimizing them? It takes me 20s to load it but I only have 2M internet.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Queue-it
      By Queue-it+
      Hi,
      Our site has experience an huge down load time since yesterday and we can't find the solution at the moment. 
      Could you also have a look at that? https://queue-it.com/
      We have plenty of plugins that are not up to date, but we have a replicate of this site that has the same exact settings and updates with plugins but it performs a lot better.
       
    • novusweb
      By novusweb+
      We're seeing an abnormal break in widgets in Safari (El Capitan v10.11.4). 3 Widgets set for 4 of 12 columns each breaks correctly in Chrome and Firefox, but the 3rd widget goes to another line in Safari.
      Screenshot attached.
      Hoping there's a CSS fix you could recommend in the meantime, until an update. You can see this on our home page: www.novusweb.com.
    • ppotent
      By ppotent+
      It seems that whenever media is set to be on the left, there is a problem with the way safari displays them. I used to have boxes with media on left when i was using DMS2, but since PL5, I've had to use only media on top. I know there are a few css suggestions that people have offered, but I'm wondering if such suggestions can't be built into the boxes code for PL5 rather than having to add extra CSS. Otherwise, am really liking PL5 over DMS2.

    • David Shelton
      By David Shelton+
      I use Adobe's Fonts.com for specific branded fonts for our site, and it's working nicely on Chrome and Firefox. However, the fonts all default in Safari. Is there anything I need to look at?
      http://madeintheshadeblindsfranchising.com
    • thesongchanneler
      By thesongchanneler
      Hello. Have you come across this problem? I'm building my website in google Chrome, and all my pages open. But if I (or someone else) uses Safari (maybe other browsers too?) the home page opens, but then when they click on a widget, the inked page shows my header and nav but a 404 Error symbol for everything else. Is there a plug in or something I can do to fix this?
       
      Thank You!
       
×