Jump to content

Archived

This topic is now archived and is closed to further replies.

evscicats

Nextbox not rendering shortcodes

Recommended Posts

evscicats

I'm having an issue getting shortcodes to work using the Nextbox section since Wordpress updated to 2.4.4 where they fixed a security issue with shortcodes and caused plugin developers who utilize shortcodes to update their code.  I can get shortcodes to work if they are created using php but if they are shortcodes from a plugin such as Custom Content Shortcodes, they don't work.  Even trying to use a simple shortcode like [field title] on a page doesn't render the page title anymore like it did before the WP update.  The Custom Content Shortcode plugin has been pushing updates to remedy issues since the WP update and I can get the shortcode to work if I put it in WP Content, but if I try using the Nextbox section, I just see [field title].

I don't know if there's something you guys need to update on the Nextbox section or if there's something you can tell me codewise to pass along to the developer of this awesome plugin to allow this to work again in Nextbox, but I need to get this working ASAP!

Thanks!

Jerrad

Share this post


Link to post
Share on other sites
Simon

Can you provide the exact shortcodes you are using, ive never used this plugin before..

Heres what I get...

Screen_Shot_2015-08-05_at_20.42.33.thumb

Share this post


Link to post
Share on other sites
evscicats

Thanks Simon for responding.

[field title] should display the title of the page or post.

I have some HTML in my code before the shortcode appears.  Try encasing it with <div class="row"> at the beginning and of course </div> at the end.  

 

Share this post


Link to post
Share on other sites
Simon

like this?Screen_Shot_2015-08-05_at_21.04.42.thumb

Share this post


Link to post
Share on other sites
evscicats

Sorry but for some reason my next response showed up in my previous response.  Here it is again.

I have some HTML in my code before the shortcode appears.  Try encasing it with <div class="row"> at the beginning and of course </div> at the end.  

I wonder what's going on with my site then?  I'll try to delete the section off my website and reinstall it to see if that fixes it.  Will report back in a few minutes.

Thanks - Jerrad

Share this post


Link to post
Share on other sites
Simon

im using this:

<div class="row">
[field title] is the post title
</div>

It still works..

Is WordPress up to date? 4.2.4?

Share this post


Link to post
Share on other sites
evscicats

I'm up to date on Wordpress and all my plugins.  

Here's the link to a test page that I have pictured below.  http://evscicats.com/test-page/

 

2015-08-05_15-20-24.jpg

Share this post


Link to post
Share on other sites
Simon

I added the same code to a page and a post now, both rendered correctly, im afraid this is pointing to your install as the issue :/

Share this post


Link to post
Share on other sites
evscicats

Simon,

I assume when you say you think it's my install that it might be another plugin causing the issue.  If you think it's something else, please let me know.

I really would like to figure this out without having to deactivate a bunch of plugins making my site fall apart in the process.  Is there a way to use Chrome or Firefox Web Developer Tools to figure this out?

Thanks,

Jerrad

Share this post


Link to post
Share on other sites
Simon

No, i think something else is screwing with the filters that your content shortcode plugin uses.

It isnt a js/css issue, its a plugin.

Share this post


Link to post
Share on other sites
evscicats

I just added the WP Content/Loop Section to the layout and added the same code to the page content and it rendered fine in that section but still not in the NextBox.  Why do you think that is?

 http://evscicats.com/test-page/

Share this post


Link to post
Share on other sites
evscicats

Found the plugin that was causing the issue - Content Paginator.  It's a plugin by the same developer as Custom Content Shortcode.  It's still in beta and he hasn't had a chance to update the code to work with the latest Wordpress.  Forgot that I had it running on my site.  

@_Simon_ Thanks for helping me troubleshoot the issue.

This issue is resolved.  Thanks!

Share this post


Link to post
Share on other sites
batman

Hi evscicats

Thanks for informing us that the issue has been resolved. We appreciate it.

;)


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites

  • Similar Content

    • casseysdesigns
      By casseysdesigns+
      In the past I would use nextbox for this task. However, Platform 5 does not have nextbox. I will do my best to describe what I am trying to do.
      I am creating a template for coaches, each product has its own link but they all share a common coach id. I want to set up the templates with the links for each product with a variable for the coach id so that I can change the coach id for all the links on the site by just changing the value of the variable $coachId. To do this I'll need to do something like the following...
      <a href="salesite.com/productcodes/referringRepId=<?= $coachId ?>" target="_blank">Product Purchase Link</a> Is it possible to do this with Platform 5?
    • quinntinm
      By quinntinm
      Hello.
       
      I need to display a shortcode in the footer of my site and have been told by the support admin to add a function in my functions.php file or use hooker.
      I installed hooker and i have no idea how to proceed.
       
      I went to the hooks editor and am faced with a list in a dropdown menu....
       
      um...
       
      So where to from here.
       
      so this is what i need to do:
      I have created 3 custom fields using advanced custom fields.
      I need to display that data in a PLNEXTBOX in the footer of the site so that the info is displayed on every page of the site in the footer.
       
      How do i use hooker to do this?
       
      Thank you.
    • abuzzelli
      By abuzzelli+
      I'm trying to translate custom PHP templates that a developer coded into pagelines templates. I'm trying to paste the php into a nextbox, but I'm getting this error:
       
      Looks like your NextBox PHP resulted in an error :/
       
      Here's the code. Not sure what I'm doing wrong.
       
       
      <?php
      /**
       * The template used for displaying page content in front-page.php
       */
      ?>

          <article id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
              <header class="entry-header">
                  <?php if ( ! is_page_template( 'page-templates/front-page.php' ) ) : ?>
                      <?php the_post_thumbnail(); ?>
                  <?php endif; ?>
                  <h1 class="entry-title"><?php the_title(); ?></h1>
              </header>

              <?php get_template_part( 'content', 'vehicle-gallery' ); ?>

              <div class="entry-content">
                  <?php the_content(); ?>
                  <?php wp_link_pages( array( 'before' => '<div class="page-links">' . __( 'Pages:', 'twentytwelve' ), 'after' => '</div>' ) ); ?>
              </div><!-- .entry-content -->
              <footer class="entry-meta">
                  <?php edit_post_link( __( 'Edit', 'twentytwelve' ), '<span class="edit-link">', '</span>' ); ?>
              </footer><!-- .entry-meta -->
          </article><!-- #post -->
    • chules
      By chules+
      On my website I've been using the standard TextBox that has field to enter a title and select a title wrapper, for example <h3>.  On 1 of my site pages I'm using both the PLNext Box that is displaying code better than the standard TextBox and underneath this a Standard Text.
       
      I'm looking to see how I can coordinate a uniform size for both the PLNext Box Standard title and the TexBox title.  Using PLNext there is no option to set a title wrapper and specify the size of the standard title.
       
      For example, how would I set both titles to be <h3>?
       
      Thank you for the assistance
       
      Chules
×