Jump to content

Archived

This topic is now archived and is closed to further replies.

swiftitnz

Viewport Animation breaking site

Recommended Posts

swiftitnz

Hi Guys,

I have been working on http://versiontwo.trustbasedrealestate.com/ for some time and use DMS2 (skeleton as child theme) for it. The primary domain (http://trustbasedrealestate.com/) is forwarded to the 'versiontwo' site with permanent forwarding + url masking. 

The trouble I'm having is, when I load the site with http://versiontwo.trustbasedrealestate.com/ url, the site and all the contents( including the viewport animations) load fine. However, when I try to load the site with http://trustbasedrealestate.com/ url, the site doesn't load correctly.

Please note:

  1. I'm not using any caching plugin
  2. I checked the URL forwarding and it's all ok
  3. Tried with 3 different browsers, even with cache/cookies emptied.

Can anyone please suggest anything?

Thanks in advance.

 

 

 

Share this post


Link to post
Share on other sites
Danny

Hi,

I am not sure what you mean, as when I go to trustbasedrealestate.com it redirects me to your versiontwo. So I am unable to see the issue. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
swiftitnz

Hi Danny

Yes you're correct that the primary URL redirects to versiontwo...

However, when I type trustbasedrealestate.com in the browser the following error occurs:

spk9lh.jpg

16c0w8j.jpg

rhsya0.jpg

Funny enough that when the entire new url (versontwo.....) is typed, the entire site (animations) loads correctly.

Thanks again for your time and support.

 

 

Share this post


Link to post
Share on other sites
Danny

This is because the domain of parent page and the its origined iframe page must be same to access parent frame javascript from child frame javascript or jquery. This is a basic security feature which prevents javascript injection from cross-domain sites.

You will probably want to review this article which may assist you - http://javascript.info/tutorial/same-origin-security-policy

Please be aware that this isn't an issue with DMS, but how you have setup the domain redirect.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
swiftitnz

Awesome explanation in the link. Now our hosting is through Godaddy and I've just changed the url forwarding type from 'with masking' to 'forward only' which temporarily solved the problem. 

I know the issue isn't with DMS, but could you suggest a permanent fix for this please? 

 

Share this post


Link to post
Share on other sites
Danny

As this isn't an issue with our product, we will be unable to assist further. Therefore, I think you're best of speaking to your web host and ask them for further assistance or post this question on StackOverFlow and see what they recommend.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
swiftitnz

Fair enough Danny. I still highly appreciate your time and support. 

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      Hi, sometimes this happens, a footer image suddenly gets this animation on it, look at the video link here so you get what I talking 'bout.
      Can't recall that I've done something to make this happen..
       
    • bartok
      By bartok+
      Why is the auto animation on my quickslider not disabled? Why is it automatically animating? I have the option unchecked in settings but it continues to animate automatically. Answer? Webpage is: grantturck[dot]com/digital
    • Mats
      By Mats
      Hi,
      I have a problem if you look at the website below it looks fine on a PC, laptop or a tablet. However when you use a phone the Quickslider animation appears too small. Is it possible to not show the Quickslider animation in the mobile version or replace it with another picture or animation? How do I do that? I have been looking into visibility, media queries and even viewport but can not find any answers to my problem.
      http://www.stallhultman.se/
    • tjolin
      By tjolin+
      Hi all, 
       
      Anyone knows how to disable the transparency on the "translate on scroll" animation? 
      Been going crazy trying to edit this for the last couple of weeks. 
       
      TIA!
    • mccooluk
      By mccooluk
      Some of the built in animation effects on Pagelines can cause problems when using mobiles/iPads as they only kick in once the user stops scrolling, meaning it is possible to scroll past a section without seeing the content, for example, mediabox images that fadein.
       
      I would like to turn off/disable animations on mobiles/ipads. From another post I found the following:
       
      <script>
      jQuery( document ).ready(function() {
        var width = jQuery(window).width()       
          if( width < 480 )
          jQuery('div').removeClass('pl-animation')
      });
      </script>
       
      Unfortunately this disables the mediabox image from loading at all. Is there a way to set it so that the pl-animation is disabled, but after the animations have taken place?
       
      Thanks
       
      Chris
×