Jump to content

Archived

This topic is now archived and is closed to further replies.

21thirteen

Modal Popup Manual Trigger Not Working

Recommended Posts

21thirteen

I've used the Modal Popup for an optin form on http://thecommonthreadgroup.com for both an automatic popup on the home page and a manual popup on every page of the site by using a different Custom Modal ID - no problem - they both work.

I'm trying to use just the manual trigger on this site under development: http://seidner.21thirteenhost.com/

I've got the section in the superfooter (I've tried it in other places as well) and a manual trigger on the superfooter as well as in the sidebar here: http://seidner.21thirteenhost.com/category/blog/

It is not working. The difference is that in this site I'm using the Easy Smooth Scroll Links plugin, Version 2.0, by Jeriff Cheng.

Obviously there is a conflict here and I don't understand enough about this sort of thing to do anything about it. I really need to use both plugins.

I'm more of a web designer with some pretty decent knowledge of html and css, and not a php guy. ANY help would be greatly appreciated.

WP and DMS2 versions are totally update, as are all plugins.

Additional data is that there is a place in the ESSL plugin for "Exclude Anchors Beginning With ( default is #tab #quicktab #pane )" and "Exclude Anchors Exactly Match". I've put #ModalPopUp, #Modal, and Modal in the provided fields, but still no go.

Thank you in advance,

Perry

Share this post


Link to post
Share on other sites
Danny

Hi Perry,

When you say you're using Modal Popup, what are you referring to?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
21thirteen

Hi Danny, I'm referring to the Modal Popup Plugin I got from Pagelines for DMS 2:

http://www.pagelines.com/shop/third-party-extensions/modal-popup-dms/

I did some more research and found this:

-----------------------

1) go to plugins=> editor and select the EASY SMOOTH plugin.

2) select file: easy-smooth-scroll-links/index.php

3) locate section : " // More code using $ as alias to jQuery "

4) after the following code: " :not([href^='#pane']) " add " :not([data-toggle='collapse']) " (without the " of course).

5) save the file and give it a go.

PLS NOTE - YOU MIGHT STILL HAVE CONFLICTS WITH OTHER JS / JQUERY ELEMENTS.

---------------------

I gave it a go but no go - "m not a php guy but I suspect that this was written specifically for tabs.

Perry

Share this post


Link to post
Share on other sites
21thirteen

ps - only guessing, but I also tried the above with :not([href^='#ModalPopUp']) and :not([href='#ModalPopUp'])

 

still no go - the popup will not trigger when clicking the button... :(

Share this post


Link to post
Share on other sites
Danny

Hi,

If you're having issue with a store product that is not developed by PageLines, you need to post you question in the correct forum. I have now moved your topic to that forum, as this is a third party product and we do not provide support to third party products.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
21thirteen

Thank you very much, Danny - I appreciate it. Where would I go to keep my eye on that forum?

Perry

(Never mind I see - thanks again)

Share this post


Link to post
Share on other sites
Danny

Its the store forum, then choose the Products by Chris forum.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • abuzzelli
      By abuzzelli+
      I need the modal popup background to be solid and I can't get the css to work. Not sure what to do. Here's the page: http://bellissimoplasticsurgery.com/breast-augmentation-test-page/
    • ade55
      By ade55
      Just installed this and can only get the header to appear in the popup.
       
      I've tried plain text in the body or selecting a page to show its content but only ever get 1 line of header
       
      see here for example.
       
      http://fishingtails.co.uk/about-us/
       
      press push me button to activate popup
    • Claude203
      By Claude203
      Hi, the Modal Popup is working fine. But whenever I look on the DMS Editor, that section is gone. It was placed at the bottom of the Footer. The first time it happened, I thought maybe I had inadvertently deleted it, or not saved properly. So I re-created another one. And so on. Then I finally realized it was working after all. But now I'm wondering if there are several of my popups in place, all of them the same, yet none of them visible, but yet all of them working. I've tried adjusting/saving into a new page template. I've tried turning on/off the DMS Editor. Still can't find a trace of the Modal Popup section, yet I know it works because I used Safari and Firefox to confirm, even on a different computer. Thanks for any help/insight you might provide.
       
      http://www.blackfives.org
    • pauloso
      By pauloso
      Dear Chris,
       
      I have a page with multiple pop-ups.
      When user clicks on the link it was supposed to open the pop-up.

      But when we click it opens up the pop-up and immediately closes it.
      I tested it on many browsers and all had the same strange behavior.

      You can see it on page: http://qualitaexpress.com.br/etapas-de-uma-importacao/
      Click on any of the links under the main big icons.

      Or click on any of the buttons on page: http://qualitaexpress.com.br/servicosparaimportacao/

      I have WordPress 4.0.1 running iBlogPro theme.
      Any idea on how to fix it?
      Thanks
    • Claude203
      By Claude203
      There is an odd problem that seems to have started only this week. It is that when I edit or add the Modal Popup section in the footer (we are using WHP6 Footer) the footer itself disappears and all that is left is the exit button, visible in place of the footer. I tried to delete the Modal Popup section and start over, but that just replicated the same problem. So I am wondering, did something change with this section? It was working perfectly prior to me trying to edit it this week. Thank you very much.
×