Jump to content

Archived

This topic is now archived and is closed to further replies.

MrFent

Ontraport form conflict with DMS

Recommended Posts

MrFent

I am using the CMS Ontraport. I have a smart form that I built and am trying to embed on my site. The problem is that when I view the page with the DMS Editor turned on, the page won't load. Here is the smart form code:

<script type="text/javascript" src="//forms.ontraport.com/v2.4/include/formEditor/genbootstrap.php?method=script&uid=p2c28761f3&version=1"></script>

Here is the error code I am getting in the chrome console:

Uncaught TypeError: jQuery.easing[jQuery.easing.def] is not a function

 

Anyway to replicate the problem, just copt and paste that script to a page and view it with the DMS editor turned on.
 

Share this post


Link to post
Share on other sites
Danny

Hi Chris,

You may want to contact their support as it is likely an issue with their script that is conflicting with the DMS Visual editor code/scripts.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MrFent

The javascript error that I posted is coming from pl.helpers.js?ver=174e85:695. Ontraport said the issue is with DMS

Share this post


Link to post
Share on other sites
Simon

the script you are linking to is offline, so i cant test what it does.

pl.helpers extends jquery.easing. jquery.easing is loaded in DMS header as a script, im guessing your form loads its own version of jquery/jquery.easing thus breaking everything.

Have you tried loading that form in an ifframe to isolate it?

Share this post


Link to post
Share on other sites
MrFent

I just tested the script and it's online and working just fine. Here is the ontraport hosted page with that script:

http://cfl.ontraport.com/f/1/28761/3/82942f65e21db03f1451f3e1891cbceb

 

I've also got it loaded here:

http://www.culturedfoodlife.com/sandbox/

 

I can load the form in an iframe and it works but the form loads very slowly. The javascript version is much preferred.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×