Jump to content

Archived

This topic is now archived and is closed to further replies.

dnnyboy

urls changed from http to https

Recommended Posts

dnnyboy

Last week we noticed that a number of images on our site weren't loading properly:

https://www.museion.ku.dk/wp-content/themes/pagelines/sections/navbar/navbar.js?ver=4.2.2 Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/features/script.cycle.js?ver=2.9994 Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/branding/twitter.png Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/branding/facebook.png Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/branding/linkedin.png Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/branding/youtube.png Failed to load resource: net::ERR_INSECURE_RESPONSE
https://www.museion.ku.dk/wp-content/themes/pagelines/sections/branding/google.png Failed to load resource: net::ERR_INSECURE_RESPONSE

The reason being that the URLs had https instead of http in front. However, there had been no change on our part on the site, and after a few hours it was apparently back to normal.

Was there any updates being pushed out or something else that could explain this?

Thanks.

Share this post


Link to post
Share on other sites
Simon

An admin must have logged in via https and saved the settings somewhere. The urls would then have been saved as https.

Share this post


Link to post
Share on other sites
dnnyboy

Huh. I'd love to be able to reproduce this problem as to be able to avoid it. Can you come up with an example of which settings I would need to save for this to happen?

Share this post


Link to post
Share on other sites
Simon

If you login to your site via https then make any changes, the frameworks cached css will use https in the urls.

If you login via http then make any changes, the frameworks cached css will use http in the urls.

Share this post


Link to post
Share on other sites
dnnyboy

Hi Simon,

I've tried to replicate this, but I can't. I've logged in via https and made changes (both WP and Pagelines config), but the site still loads fine. No URLs are changed to https, it seems. Note that a number of the elements that didn't load when we had the problem were social media icons that aren't part of the css (afaik?)

Share this post


Link to post
Share on other sites

×