Jump to content
Sign in to follow this  
tangtangsworldde

Custom Code moving from iBlogPro3 to iBlogPro4

Recommended Posts

tangtangsworldde

Hi, trying to switch my website from BlogPro3 to iBlogPro4. I first copied my old custom code and started with empty custom code field in Pro4, cause the html is a little different there. I placed the old an new pages side by side in tabs and then started using Firebug to read the old websites html values and making modifications on the new Pro4 site with firebug. Once satisfied withe the values, I copied them and placed tehm into the custom code window and safed. Unfortunately Pro4 didnt take the new values. Firebug was showing my new CSS with my websitename but alle crossed out and the default values of Pro4 were still up. What did I do wrong? First I thought that WP-Super-Cache was the problem, so i switched it off. No difference. I love the custom code way of modifying and dont want to go to an external editor after every update. Im sure, its a simple mistake. Looking forward for your assistance. By the way. After finishing the transfer I will provide you with a german po./mo. again, like I did with Pro3 :)) Thanx in advance Tang

Share this post


Link to post
Share on other sites
cmunns

Tang, Likely a slight change in hierarchy or organization of iBlogPro4. You may need to be more specific with your CSS rules. Try adding `body` to the front of all your CSS to see if it makes a diff

Share this post


Link to post
Share on other sites
tangtangsworldde

Adam, that's the trick I was missing. In my old custom code I just had body{} on the top of everything and it worked. Now it has to be in front of every single css-style like in the following example - is that right? By the way (I'm not a programmer) - if I just want to edit for example the font-size in:

body
	#feature .fheading h1, .ftitle {
			[b]font-size: 	55px;[/b]
			line-height:  0.9em;
			letter-spacing: -0.05em;
			font-weight: 400;
		}

would you recommend to have the other unchanged values in the custom code as well or just the edited font-size in this case?

Share this post


Link to post
Share on other sites
cmunns

I would only include what's changed so you can more easily navigate through what you've done.

Share this post


Link to post
Share on other sites
tangtangsworldde

Yep ??¦ site is improving ??¦ still some customizing work left ??¦ Now I want to get rid of the doubled home button in the main navigation. Switched to WP 3.0 menues with ?»home?« not included. But unfortunately it's still showing up. How do I make it invisible and just keep the little house-icon-menue? see my homepage-navigation f.ex. http://www.tangsworld.de

Share this post


Link to post
Share on other sites
bryan-hadaway

If all else fails: `#nav .page-item-19{display:none}` Thanks, Bryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×