Jump to content

Archived

This topic is now archived and is closed to further replies.

JudithKlinger

Leverage Browser Caching, Expiry Date

Recommended Posts

JudithKlinger

I ran Google Developer's Page Speed Insights, and it's recommending that I should leverage browser caching on specific files. 

Here's the text: Setting an expiry date or a maximum age in the HTTP headers for static resources instructs the browser to load previously downloaded resources from local disk rather than over the network.

 

I've never done this & before messing around with the .htaccess file (gulp!)... is there anything I should be aware of with DMS and expiry dates? Is there a plugin that would make this easier? CloudFlare? 

 

I had been working in NoCache mode as we did some big additions, and was hoping that once I went back to cache mode it would miraculously clear up...but I'm not that lucky. 

 

Grazie!

Judith

http:://world-eats.org

Share this post


Link to post
Share on other sites
Danny

Hi Judith,

 

There should be no issue with expiry dates and DMS. If you wish to follow the guidance of Google, you can try this plugin (depending on your server setup) - https://wordpress.org/plugins/leverage-browser-caching-ninjas/

 

Or read the following article - https://thomasgriffin.io/how-to-leverage-browser-caching-in-wordpress-via-htaccess/

If you encounter any issues performing these tasks, you will need to contact WordPress support.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JudithKlinger

Ciao Danny...you know I'm all about a nice easy plugin! I was sooo hoping that would be your response. 

Giving it a whirl now, and will report back. 

Just FYI...seems that plugin has been updated to the current version of WP. Hopefully, it won't make a difference. 

Grazie! 

Share this post


Link to post
Share on other sites

  • Similar Content

    • jeomiland
      By jeomiland+
      In DMS2 there was a button to click to flush pagelines cache. Don't see this in platform5. Am having a big problem with caches. Have W3 Total cache plugin, but now even if I deactivate it, the code in css/less seems to not be registering??? I can delete all custom css, save, then add just a bit of the css (that used to work just fine the other day) and that small section of css takes effect. Then when I paste the whole css (that worked fine the other day), it seems to not work???
      About to restore DB backup from a couple days ago to see if that solves it, but it's a drag that this issue exists. Makes it hard to finetune the site.
      Thanks for help
      site is: http://permacultureecovillage.com/lev2017/
      lev styles most recent.css.rtf
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • richardjacruz
      By richardjacruz+
      I noticed that the cached version of the website from a Google SERP has broken CSS:
      http://webcache.googleusercontent.com/search?q=cache%3A1uyPM2gXGG0J%3Astevensoncrane.com%2F+&cd=16&hl=en&ct=clnk&gl=us
      Any idea why? The site looks fine elsewhere.
      Also, when using the Web Developer Toolbar in Mozilla Firefox, there are a BUNCH of warnings regarding CSS. I'm wondering that's the problem with the Google cache.
      In a prior post, I had experienced similar "breaking" of the CSS, but that was due to some errors in DNS. I thought we resolved all of that, so this perplexes me.
      Thanks,
      Rich
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
×