Jump to content

Archived

This topic is now archived and is closed to further replies.

renaud.moulas

All page tempaltes disappeared

Recommended Posts

renaud.moulas

Hi,

Few minutes ago, I connected to my wordpress console and I tried to edit one of my page with DMS2 editor.

After the DMS editors loaded I discovered that all my page templates disappeared with following message : 

Notice: Undefined index: name in/home/prochaingj/www/wp-content/themes/dms/dms/editor/editor.templates.phpon line 338

 

I attached a screenshot of my the error.

 

What can I do? My website is down!!!!

Thx very much!!!

Renaud

 

website : www.prochaine-escale.com

Wordpress version : 4.2

Share this post


Link to post
Share on other sites
renaud.moulas

Few more information avout what I just tried: 

1/ remove all plugin > KO

2/ change wordpress Them then go bock to my child them > KO

 

Thank you for your help.

Share this post


Link to post
Share on other sites
renaud.moulas

I attached a new error message displayed in wordpress console.

Share this post


Link to post
Share on other sites
renaud.moulas

With the first attachment...

Share this post


Link to post
Share on other sites
renaud.moulas

I've just done few other tests: 

1/ remove pagelines theme from FTP and re-install dms theme > KO

2/ remove and paste from DMS original folder the file /themes/dms/dms/editor/editor.templates.php > KO

 

This bug is affecting all my pages linked to a dms page template (90% of my webstite pages). All pages not linked to a page template are working well.

An example of a page linked to a template : http://www.prochaine-escale.com/

An example of a page not linked to a template : http://www.prochaine-escale.com/destinations/cuba/ouest-cubain-et-detente-dans-les-caraibes/

 

Thank you for your answer.

Renaud

Share this post


Link to post
Share on other sites
renaud.moulas

In addition to my previous comment, here is another information provided by the plugin Debug Bar (just intalled) when I load pagelines editor :

  1. NOTICE: wp-content/themes/dms/dms/editor/editor.importexport.php:129 - Undefined index: name
    require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/dms/index.php'), setup_pagelines_template, get_footer, locate_template, load_template, require_once('/themes/dms/footer.php'), pl_get_core_footer, require_once('/themes/dms/dms/footer.php'), wp_footer, do_action('wp_footer'), call_user_func_array, PageLinesTemplateHandler->json_blob, EditorSettings->get_set, apply_filters('pl_settings_array'), call_user_func_array, PLImportExport->add_settings, PLImportExport->option_interface, PLImportExport->export_template
  2. NOTICE: wp-content/themes/dms/dms/editor/editor.importexport.php:130 - Undefined index: desc
    require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/dms/index.php'), setup_pagelines_template, get_footer, locate_template, load_template, require_once('/themes/dms/footer.php'), pl_get_core_footer, require_once('/themes/dms/dms/footer.php'), wp_footer, do_action('wp_footer'), call_user_func_array, PageLinesTemplateHandler->json_blob, EditorSettings->get_set, apply_filters('pl_settings_array'), call_user_func_array, PLImportExport->add_settings, PLImportExport->option_interface, PLImportExport->export_template
  3. NOTICE: wp-content/themes/dms/dms/editor/editor.templates.php:338 - Undefined index: name
    require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/dms/index.php'), setup_pagelines_template, get_footer, locate_template, load_template, require_once('/themes/dms/footer.php'), pl_get_core_footer, require_once('/themes/dms/dms/footer.php'), wp_footer, do_action('wp_footer'), call_user_func_array, EditorInterface->pagelines_toolbox, EditorInterface->panel, call_user_func, EditorTemplates->user_templates
  4. NOTICE: wp-content/themes/dms/dms/editor/editor.templates.php:340 - Undefined index: desc
    require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/dms/index.php'), setup_pagelines_template, get_footer, locate_template, load_template, require_once('/themes/dms/footer.php'), pl_get_core_footer, require_once('/themes/dms/dms/footer.php'), wp_footer, do_action('wp_footer'), call_user_func_array, EditorInterface->pagelines_toolbox, EditorInterface->panel, call_user_func, EditorTemplates->user_templates

Share this post


Link to post
Share on other sites
Danny

Hi,

 

When you say you were editing one of your templates, what was you editing and have you added any custom code or made any changes to the core files ?

 

Can you go into greater detail as to what you were doing before you encountered the issue ?
 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
renaud.moulas

Hi Danny,

I was editing a page template using DMS editor (drag and drop editor). The only thing I added to the page is a shortcode provided by Search and Filter Pro plugin.

I didn't touch any of DMS theme core files.

 

To summarize:

Yesterday morning: everything worked perfectly. At 10 AM I installed a new plugin : Search and Filter Pro

Between 10AM and 7PM: I customized my page using DMS editor (add new sections and the shortcode provided by the plugin)

Yesterday 7PM : all page templates were missing and all pages linked to a page templates were unvailable.

 

So I tried to remove the plugin Search and Filter. Then I tried to deactive/active all plugins 1 by 1. But any of these actions solved my problem. All DMS page templates are still missing.

 

Does that help?

Share this post


Link to post
Share on other sites
renaud.moulas

One more thing I did yesterday : I added 2 new custom taxonomies using function.php file (the one in my child theme). But I did these changes during the morning too.

Share this post


Link to post
Share on other sites
renaud.moulas

I did few other tests : 

1/ I removed by FTP my wordpress folder and uploaded an older version of the folder (saved 1 month ago).

However it did solve the issue. Unfortunatly I couldn't do the same test with my database (I did create a copy).

So i think the problem comes from DB... but it's just an assumption.

Please help me!!! The site is down :(.

Renaud

 

Screenshot of error 1 :

http://www.prochaine-escale.com/wp-content/uploads/2015/05/Capture1.png

Screenshot of error 2 : 

http://www.prochaine-escale.com/wp-content/uploads/2015/05/Capture2.png

Share this post


Link to post
Share on other sites
renaud.moulas

Hi Danny,

I think I understood why all my page templates are missing: I checked in phpadmin the DB status and I discovered that the table "options", line "pl-user-templates" doesn't contain all my page templates. All the templates I created after the bug are correctly added in the line but all the templates I created before the bug are missing.

Do you think that's the correct explanantion? Is there a way to restore the templates (I checked in the table "pl_data_sections" and all data seem to be here)?

 

Do you have an idea of what could have cause this issue? And more important how I can prevent this from happening again?

 

Thx.

 

Screenshot phpadmin: http://www.prochaine-escale.com/wp-content/uploads/2015/05/Capture.png

Share this post


Link to post
Share on other sites
Danny

As far as I can tell this isn't a bug. If your site was working before you installed and added the shortcode from the Search and Filter plugin then it is very likely that either the plugin has caused a conflict or the custom code you have added via the child themes functions.php file has caused the issue.

Therefore, seeing as you have resolved the issue by uploading an old version of WordPress saved from one month ago tells us that the issue has been caused by something you have either installed or added i.e. custom code.

Therefore, to completely resolve your issue, I recommend you contact your web host provider and ask them to restore your site to backup prior to you installing this plugin and adding the custom code. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
renaud.moulas

Hi Danny,

Thank you for the feedback.

Fianlly, I could found a backup of the site. So the issue is solved.

 

However there is another issue/conflitct caused by the plugin Search and Filter Pro.

It seems there is a conflict (may be linked to my initial issue) when I active the plugin.

The DMS editor consol change (colors, font types) when I turn on the plugin and some feature are broken:

DMS editor without the plugin : http://www.prochaine-escale.com/wp-content/uploads/2015/05/dms1.png

DMS editor with the plugin :  http://www.prochaine-escale.com/wp-content/uploads/2015/05/dms2.png

When the plugin is activated, I can't publish the changes I've done on the page (publish additional text in a textbox section for example).

What could cause this bug? Since I need the plugin I would really like to understand.

Thx!

Share this post


Link to post
Share on other sites
Danny

The issue is with the search and filter plugin, you will need to contact their support for assistance.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • DonRicardoRVM
      By DonRicardoRVM+
        First of all, sorry for my bad English.  I am developing an ecommeece with wp, woocommerce, PL5 and quickshop, and I need to do some changes in the simple product grid. I want to change the classes of some divs, but I can't find the templates. 
      Also, I change the grid of the category products pages, but I didn't make it correctly.
      This is the cat archive's: http://globosdemar.com/wp/categoria-producto/camisetas-para-ninos-y-ninas/
      Can you help me?
    • poseyg
      By poseyg+
      Could someone explain exactly how the new template sync works or what it is suppose to do?
    • Anthony King
      By Anthony King+
      I have to say that I like the Layout and the Template based sections. Some of them are really impressive.
      One of the things that I would like to request though is the possibility of being able to dynamically rearrange the layout.
      An example of what I am talking about is take the Agency Section. It's current layout starts with the
      Splash Module then the Portfolio Module then the Service Module and so on and so forth.
      What would be great is if we were able to move these modules around. I.e have the Service Module first
      then maybe the Splash, and then the portfolio.
       
    • flourishdesignstudio
      By flourishdesignstudio+
      I am using Jigoshop on a website that also uses PL5 and am running into an issue where the store pages do not allow me to use the PL5 editor. Is anyone else having this problem or know if a solution? 
      When I open the Chrome console I see the following error:
      site.js?ver=b199df:5 Uncaught ReferenceError: PLData is not defined
          at Object.setMasterModel (site.js?ver=b199df:5)
          at Object.init (site.js?ver=b199df:5)
          at HTMLDocument.<anonymous> (site.js?ver=b199df:5)
          at i (jquery.js?ver=1.12.4:2)
          at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
          at Function.ready (jquery.js?ver=1.12.4:2)
          at HTMLDocument.K (jquery.js?ver=1.12.4:2)
       
      The problem can be seen here: http://fingerlakesdistilling.com/shop/ where the sidebar, footer, and header do not show up. Any thoughts?
      Thanks so much!
    • Queue-it
      By Queue-it+
      I've created a new post category "Success stories" with Custom Post type UI. (in order to have a different layout for a different post category - blog post one layout, success stories another layout).
      New category "success stories" are "detached" from all the other posts, so they have a different layout, but the problem is that all of the success stories are also having the same exact content.
      So whenever I edit content (e.g. change body text) on one of success story posts, it also changes the content (body text) for all other Success story category posts. 
       
      Question: Is there a way to retain this separate category with it's own layout, and have a different content for each individual post? I'm using Pagelins templates. 
       Thanks in advance.
×