Jump to content

Archived

This topic is now archived and is closed to further replies.

dgsarnow

Scaling down h1-h6 in the template area

Recommended Posts

dgsarnow

Does anyone know how to scale down the h1-h6 tags within the template section?

 

I want to keep the native sizes in the header, fixed bar, and footer sections.


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
Danny

Hi,

 

I apologise, but I am not entirely sure what you're referring to, can yo go into greater detail please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dgsarnow

Danny, sure.

 

Right now here are the current sizes that are being rendered for my h1-h6 styles.

H1 font-size: 50.4000015258789px;

H2 font-size: 43.2000007629395px;

H3 font-size: 32.4000015258789px;

H4 font-size: 25.2000007629395px;

H5 font-size: 19.7999992370605px;

H6 font-size: 18px;

 

I want to reduce these font sizes so they do not display so large, but I know things scale when on mobile devices. I do not want to do anything that interferes with that.

 

Any suggestion?


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
Danny

Can you provide a link to a page where these header tags are being used so I can see their sizes. As the sizes you have posted above do not as far as I am aware meet what is styled in DMS by default.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

I have reviewed your site and the with the exception of the Widget title <h2> all other headers on that page, as far as I can tell, have all been given a custom class by you. However, if you want to reduce the header size, you can do this with CSS.

 

h1 { font-size: 1000px; } and so forth...


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dgsarnow

Danny, thanks for looking into this. My custom classes are just for font-family, font-weight and color. I am not modifying font-size at all. I know I can change them individually, but I wanted to make sure I did not mess with anything you guys do natively when displaying the site on a mobile device.

 

I know how media queries work, but I love to keep my CSS as uncluttered as I can. Thoughts?


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
Danny

What I would suggest is, create unique classes for your header font-sizes instead of overriding the h1, h2, h3, individually. Unless, you can't do that for example you can not add a class to the widget title class, so you will need to override it.

 

For example, create a class called big-title, then add this to your h1, h2 tags like so: <h1 class="big-title">This is a header 1 tag</h1>

 

Then use the following CSS:

 

.big-title {

  font-size: 36px;

}

 

You can repeat this process for smaller titles to, such as main-title, large-title, small-title, big-header, small-header etc.. then add CSS rules with different font-sizes for each so you have multiple to choose from and these can be reused again and again.

 

You can also also use media queries on those classes to give you control on mobile devices and specific screen widths.

Alternatively, you can just add the following:

 

h1 { font-size: 86px !important; }

h2 { ... }

 

and so forth.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×