Jump to content

Archived

This topic is now archived and is closed to further replies.

webbdo

Background CSS - Any customization / design

Recommended Posts

webbdo

Hi,

 

Is there any default customization to iblogpro6 so it´s easy to manage the background for the site? Also to the main background in middle behind content? 

 

Lets say that I want to have my site like ipage (dot) com with grey background and white in middle behind content. But I also want to have the *shade* between the white/gray and also at the bottom. How do I add this to my site?

 

Kind Regards

PK

Share this post


Link to post
Share on other sites
Danny

HI PK,

 

To achieve this you will want to use Boxed Mode in the Layout settings and then apply CSS to the box layout to add the box-shadow i.e. the shadow background on the content area.

 

You can use this to give you some understanding how it works - http://www.cssmatic.com/box-shadow


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Thanks, very nice tool! 

 

When I manage this on 1 page it only fetch to that page. How do I add it to complete website - Page/post?

Share this post


Link to post
Share on other sites
Danny

The option is universal so can you provide a link to the site in question, so I can see where this is happening.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

I believe that it´s because I have unlock the templates. For example I use 3 "iBlog - About Us". On this I need to add the CCS code to every template. The only areas that is global is Head and Footer.

Share this post


Link to post
Share on other sites
Danny

Can you provide a link to the site in question please. As the background color option is universal throughout your site and not specific to certain templates or pages.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

It´s still under development. 

 

Please look at main site www.webbdo.com... Shadow only on header. Then please go to www.webbdo.com/webbhotell/ there you will see shadows in main content as well..

Share this post


Link to post
Share on other sites
Danny

Thats because you have added the box shadow code to that section specifically, using the inline styling. If you go down that route you will need to add that code to all sections.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Okey..

 

What do I need to do to add the shadow to complete page... So that all follows from the head and down to footer?

Share this post


Link to post
Share on other sites
Danny

Remove the code you have at the moment and try this instead:

 

.boxed-wrap {
  -webkit-box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36);
  box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36);
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Nice job Danny, thanks!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Behind the shadow, on both sides. Is it possible to have a nice grey background and keep the main (middle) white?

Share this post


Link to post
Share on other sites
Danny

Yes, use CSS and apply a background color to the body.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Added following code to Custom LESS/CSS:

 

 
.body {
    background-color: #F0F0F0;
}
 
It does not take affect....

Share this post


Link to post
Share on other sites
Danny

Try this:

 

#site {
  background-color: red;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
webbdo

Once again, nice and thanks!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×