Jump to content

Archived

This topic is now archived and is closed to further replies.

stephen2

Site can't find style-sheet when using HTTPS

Recommended Posts

stephen2
I've been working with FLywheel on this as its been an ongoing issue. Our site has been acting erratically - it has periods where it loads and behaves perfectly, then suddenly it can't find its style sheet and doesn't load properly. I've been in contact with Flywheel almost daily with this issue. Each time we think it's solved due to a caching issue on their side and within a day or If I push an update, the issue returns. I'm told that Pagelines doesn't work well with HTTPS? And/or doesn't like being moved from a staging environment. We're using HTTPS for HIPAA compliance and removing it isn't an option. As for staging, it's tough working on a live site - been using Flywheel's staging environment. 
Can someone help us with this? 
 
Website: 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

How have you setup your SSL. Also, what is the error given when this issue happens, do you have a screenshot ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
stephen2

Flywheel set it up and no error message. 

 

The screenshot attached is an example of what happens - this one was taken on Saturday. 

 

http://www.screencast.com/t/Bdp156Bv9

 

Clearing the Cache at Flywheel's level will temporarily resolve it. It can return within a couple hours.

Share this post


Link to post
Share on other sites
stephen2

This is an email I just sent FlyWheel. It may add insight to the problem. 

 

-----

 

I’ve logged in twice tonight (7pm-ish and 8pm-ish) because the site stopped being viewable on my iphone, then in Firefox, Safari and Chrome. 

 

I've logged in to our dashboard and cleared the cache, then logged into our website and giggled wires (save the home page, then refresh it, if that doesn’t work , I try saving another. ) I do this until I can view the site. It lasted for an hour then for an hour then at 8ish same thing. Did my little routine again, now at 9:00 pm same thing – can’t view site. 

 

Help!

Share this post


Link to post
Share on other sites
Danny

Can you ask them to provide you with the exact steps taken to add SSL to your site. As, we have a number of users who have SSL websites we have on PageLines.com and none of them have issues.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
stephen2

Flywheel's Response: 

 

"I’m not sure exactly what they’re asking, but let them know it’s the same setup that pagelines.com runs. If they have specific questions, have them reach out directly and we’re happy to help."

 

Thanks

Dusty

 

Flywheel 

Premium WordPress Hosting – Built for Designers 

http://getFlywheel.com 

 

(888) 928-8882

Share this post


Link to post
Share on other sites
Danny

If this has been setup the same as our SSL PageLines.com, then there should be no issue. Therefore, if you're having periodic issues with the stylesheet not loading, can you disable all active plugins and see if you still experience the same issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • marshallsolutions
      By marshallsolutions
      For the site https://marshallsirishpub.com I am running
      Wordpress 4.9.4
      Pagelines base theme 1.0.2
      Pagelines Framework 2.5.0
      The share bar specifically Stumble Upon is causing an error when checking SSL for HTTPS at whynopadlock.com.  Here is the errors shown:
      A file with an insecure url of "http://cdn.stumble-upon.com/js/badge_su.js?v=20120613" was loaded on line: 1 of https://www.stumbleupon.com/badge/embed/2/?url=https%3A%2F%2Fmarshallsirishpub.com%2F.
      A file with an insecure url of "http://cdn.stumble-upon.com/css/badges_su.css?v=20120613" was loaded on line: 1 of https://www.stumbleupon.com/badge/embed/2/?url=https%3A%2F%2Fmarshallsirishpub.com%2F.

      Errors that are reported on line 1 are generally not part of the source code. This error may be caused by an external javascript file which is writing to the page, however we are unable to reliably detect these scripts in our automated test.
      Please contact us using the "Need Help?" link below if you need assistance with resolving this error.
      I contacted support at Really Simple SSL which is the plugin we use to convert the site to HTTPS via SSL.  They said I should contact you guys.  Here is what their support had to say via email:
      the sharing bar seems to load the Stumbleupon script over http:// despite being trying to redirect it to https://. The cdn.stumbleupon doesn't seem to have an SSL certificate and therefore refuses to load over https://. I'd suggest to contact the developer of the sharing plugin, the Stumbleupon button can de designed in another way, without it trying to load a script over http://.
      So it seems I need to modify some file in pagelines to make the stumble upon portion of the share bar to read https and not http.  If that's not possible then I need to remove stumble upon from the share bar.
      Thanks.
    • israelgenealogy
      By israelgenealogy
      I have an old PageLines site that I recently got working with SSL, but there are mixed content errors. There are two problems I've found. One is the search button icon called from forms.less:
      url(@{plRoot}/images/search-btn@2x.png)
      The second is when PageLines loads FontAwesome from icons.less:

      url('@{iconFont}.eot?v=3.0.1');

      Where is similarly loads the font using http. Any idea why these are loading using http instead of https, and is there a simple way to fix these? I know I need to upgrade the theme, but it's a major project, so for the moment I'd just like to get these secured before taking on switching themes/frameworks.
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×