Jump to content

Archived

This topic is now archived and is closed to further replies.

canadvo

Sidebar Column Randomly Disappear from Templates

Recommended Posts

canadvo

Hi there,

 

This is a "phantom" problem we've had on our site since we upgraded to DMS2 eight or nine months ago.

 

We have a large site and depend on the template system for almost all of our pages/posts. Typically it is a two column setup, with one containing the post loop/breadcrumbs, and the other column containing a widgetizer that displays the appropriate sidebar. Seemingly at random, the entire sidebar column will disappear from a template, leaving only the main column with post loop. We've never been able to isolate the problem or duplicate it. Sometimes, it happens to templates applied to pages that we haven't edited or even visited in quite some time. Sometimes, it will happen to templates we edited/published in the previous few days.

 

I've never felt moved to post about this because the issue is impossible to predict, but it just now happened before my very eyes.

 

I had just published a page that did not have a template applied. I wanted to apply the template we use on our "about us" pages, but I wasn't sure what it was called. I clicked on a page that had the template in question applied. All elements were present, the template was fine. Once I had the template name, I navigated back and loaded the correct template on the newly-edited page. When the page refreshed, the template had loaded without the sidebar column. I stopped and switched to Firefox (where I was logged out) and found that all pages within that template suddenly had no sidebar.

 

I understand that this is an issue that is hard to provide support for, given that I've never been able to replicate it at will. Is this a problem others have had? Were there any plugins identified as a potential culprit? We have no cache plugins installed.

 

Thanks!

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you provide a link to a page that has no sidebar please, so we can investigate further. Also, make sure all plugins and custom code/scripts have been disabled/removed.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
canadvo

Well, this happened on our live site, so I already repaired the template. It's usually an easy enough fix. But sometimes when this happens, I'll fix it and then the template spontaneously breaks again after a couple of days.

 

I can't disable the plugins on our live site, at least not during business hours. I just attempted to replicate the error on our dev site, which has a nearly identical configuration, but had no luck.

 

For what it's worth, here's the page this happened to yesterday. Keep in mind the template was fine until I loaded it onto this page. http://www.canceradvocacy.org/about-us/who-we-are/board-of-directors/

 

Has anyone else on here had a similar issue?

 

Here are the active plugins.

 

Breadcrumb NAV for WordPress SEO by Yoast         by Online Profiler – 1.0
Custom Sidebars         by WPMU DEV – 2.1.0.2
DMS Professional Tools         by PageLines – 1.8.5
Google Analytics by Yoast         by Team Yoast – 5.3.3
State and Zip Field Modifier (works only with Gravity Forms)         by Marty Martin – 1.1
Gravity Forms         by rocketgenius – 1.9.4
Gravity Forms Authorize.Net Add-On         by rocketgenius – 1.6
Gravity Forms MailChimp Add-On         by rocketgenius – 3.5
Gravity Forms PayPal Standard Add-On         by rocketgenius – 2.3
Nextend Accordion Menu         by Nextend – 9.2.9
Nextend Smart Slider 2 Full         by Nextend – 2.3.11
Nextend         by Nextend – 1.3.6
PageLines Updater         by PageLines – 1.2.6
Quick Page/Post Redirect Plugin         by Don Fischer – 5.0.6
Revision Control         by Dion Hulse – 2.3.1
Shortcodes Ultimate         by Vladimir Anokhin – 4.9.4
Sidebar Manager Light         by OTWthemes.com – 1.8
Simple Share Buttons Adder         by Simple Share Buttons – 5.6
SmartSimian Creator         by Pongos Interactive – 2.1.5
SmartSimian Queries         by Pongos Interactive – 2.1.3
SmartSimian Resource Search Customs         by Pongos – 1.0.1
SmartSimian Templates         by Pongos Interactive – 2.1.3
Sucuri Security - Auditing, Malware Scanner and Hardening         by Sucuri, INC – 1.7.6
Ultimate Tag Cloud Widget         by Rickard Andersson – 2.7.2
UpdraftPlus - Backup/Restore         by UpdraftPlus.Com, DavidAnderson – 2.9.60.19
WooCommerce Amazon S3 Storage         by Gerhard Potgieter – 2.0.5
WooCommerce Customizer         by SkyVerge – 2.1.0
WooCommerce Authorize.net AIM Gateway         by SkyVerge – 3.3.1
WooCommerce - Gravity Forms Product Add-Ons         by Lucas Stark – 2.9.1
WooCommerce Subscribe to Newsletter         by WooThemes – 2.2.5
WooCommerce         by WooThemes – 2.3.7
WooThemes Helper         by WooThemes – 1.5.2
Wordfence Security         by Wordfence – 5.3.8
WordPress Importer         by wordpressdotorg – 0.6.1
WordPress SEO         by Team Yoast – 1.7.4
WP-SpamShield         by Scott Allen – 1.8.3

Share this post


Link to post
Share on other sites
Danny

If you can't replicate the issue on a dev site, did you install all the same plugins ? As I am not able to recreate the issue with only DMS installed with no other plugins.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900

Hi I can see that you have both custom sidebars and sidebar manager light active. I remember that Pagelines recommended a plugin then changed their mind with a later version  of DMS and I did have issues with sidebars disappearing until I updated them to the new plugin. Since these two plugins are managing the same thing i would stick to one. 

 

The current recommendation is sidebar manager light http://answers.pagelines.com/Customization/how-to-use-custom-sidebars

 

Not sure if that is the answer, but you could try. 

Share this post


Link to post
Share on other sites
canadvo

Hi I can see that you have both custom sidebars and sidebar manager light active. I remember that Pagelines recommended a plugin then changed their mind with a later version  of DMS and I did have issues with sidebars disappearing until I updated them to the new plugin. Since these two plugins are managing the same thing i would stick to one. 

 

The current recommendation is sidebar manager light http://answers.pagelines.com/Customization/how-to-use-custom-sidebars

 

Not sure if that is the answer, but you could try. 

 

Whoa thank you so much for the tip, nfp1900! We never had this problem with DMS1. We've used the Custom Sidebars plugin since at least the switch from Framework to DMS, but we do not Sidebar Manager Light at all. I'm not sure if Sidebar Manager Light was left over from an older theme or what, but it's one of those things where I never thought to deactivate it.

 

I'm probably going to simply deactivate Sidebar Manager Light first and see if the issue recurs. My guess is if we switched plugins, we'd have to re-make all the sidebars. If I'm wrong on that, let me know hehe.

 

Were you using Custom Sidebars when you were having this problem or a different sidebar plugin?

Share this post


Link to post
Share on other sites
nfp1900

I was using sidebar manager light and did have some issues so re-created all the sidebars in the 'approved' plugin.  At least try this and see how things progress. 

Share this post


Link to post
Share on other sites

  • Similar Content

    • jaithai
      By jaithai+
      Unable to attach an image that's already been uploaded.
      When attempting to upload one from scratch, it gives me the error seen in the screenshot. As you can see by the Chrome Inspector, I receive a 400 error.
       

    • stijnxo
      By stijnxo+
      Ik like to use the following Plug-in in my DMS Theme, but can' get it to work. My DMS Editor is not loading anymore if I paste this short code in a page, textbox or mediabox: [wpdatatable id=1]
      Plug-in: WPDataTables Plug-in 
      Shortcode:  [wpdatatable id=1]
      Website: http://gentleclinics.nl/prijslijst-heren/

      Anyone experience with this plug-in and DMS.
    • foxwatson
      By foxwatson+
      I recently downloaded the latest DMS2 update. Since the download, I lost front end ability to update. Any suggestions would be appreciated.  
    • Justin Taylor
      By Justin Taylor
      I originally purchased, I believe, a 3 site licence for DMS2. The new account interface does not reveal any of this information.
      How do I know how many licences I am entitled to? How do I reset one for a new website? All it says now is that I don't have any Pro licences?
    • Anthony CALCI
      By Anthony CALCI+
      Hello,
      I have switched from the Framwork theme to DMS theme on http://calcipatrimoine.theproofingcompany.fr (miror site of http://calci-patrimoine.com).
      But I have now only the Primary sidebar in the Widget section ! Secondary sidear, Footer sidebar have all disapear...
      Can I have help to have them back ?
      Regards,
      Anthony
×