Jump to content

Archived

This topic is now archived and is closed to further replies.

jfsturtz

Problem with script errors

Recommended Posts

jfsturtz

Hi again.

 

I'm trying to include some custom javascript in my site, and I keep getting myself into a jam when there are script errors.  Here's what happens:

  • I click on the '</> Custom' button, and then add my script (that apparently has errors in it, but I don't know that at the time; I mean, we all make mistakes, right?) to the Custom Scripts window.
  • I click on the little button in the lower left to turn off the DMS Editor, to try it out (the particular script I'm testing only works, when it doesn't have errors in it, with the Editor turned off).
  • I interact with the page and observe that the script I added isn't doing what I intended.
  • I click on Active PageLines Editor in the lower left to re-enable the editor and fix my script, and ... it hangs.

Now, I read in the documentation that script errors will sometimes cause the front end not to come up, and that there is a fallback on the PageLines page of the site.  So I go to the WordPress Dashboard, click on PageLines and get the page with the fallback editor.  I go into the Scripts section and delete the code I just added.  Then I click 'Save Scripts'.

 

But I can't get the change to stick.  If I navigate away from the page with the fallback editor to somewhere else, then go back to it again, the script I tried to delete is always there again.

 

I can't fix (or remove) the offending script from the front end, because it's hung, and I can't seem to change or remove it using the fallback editor either.  I'm stuck.

 

Any ideas?

 

Thanks again.

 

/John

Share this post


Link to post
Share on other sites
jfsturtz

Urgh.  This is truly maddening!

 

Right now, I've got an erroneous piece of script on my site.  If I use the fallback editor to edit it out, save and then refresh the page, it's right back again.  I can't figure out how to get rid of it.

 

I've noticed that when I delete erroneous script, eventually it goes away -- after many times deleting it, clearing the browser's cache, logging out of the site and back in, switching to a different theme and back again, and just about everything else I can think of.  I'm not sure what's eventually working, but every time I make a mistake in my script coding, it takes me an hour to recover.

Share this post


Link to post
Share on other sites
jfsturtz

FWIW, I've discovered I can avoid the problem by previewing my site in a separate browser window, rather than using the 'Deactivate Editor (View Live)' button ...

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Unfortunately, we can not provide support to third party scripts. However, what I would recommend is that if you're using third party scripts, I would use a child theme and the enqueue function in WordPress and not use the DMS custom scripts editor.

 

https://codex.wordpress.org/Function_Reference/wp_enqueue_script


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×