Jump to content

Archived

This topic is now archived and is closed to further replies.

Keith Vaugh

Child theme, LESS, Custom fonts

Recommended Posts

Keith Vaugh

Hi All

Apologies if this has been posted multiple times, for what ever reason its not appearing after I hit post!

I am being the process of migrating from Framework to DMS and cloned the live site a development environment on the localhost. 

 

I have disabled the Pagelines-sections plugin, installed DMS and installed a child theme based on Danny's Skeleton (see attached image for file tree)

 

The following CSS has been added the style.LESS file

@font-face {
font-family:"Champagne & Limousines";
src:url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.eot?") format("eot"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.woff") format("woff"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.ttf") format("truetype"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.svg#Champagne&Limousines") format("svg");
font-weight:normal;
font-style:normal;
font-family:"Champagne & Limousines";
src:url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.eot?") format("eot"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.woff") format("woff"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.ttf") format("truetype"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.svg#Champagne&Limousines") format("svg");
font-weight:normal;
font-style:normal;
}
.impress {
font-family: "Champagne & Limousines", "Antic Slab", sans-serif;
font-weight: 200;
text-transform: uppercase;
font-size: 40px;
line-height: 100%;
color: #5d2248;
}
.magvatag {
font-family: "Antic Slab", sans-serif;
font-weight: 300;
font-style: normal;
font-size: 25px;
line-height: 120%;
color: #5d2248;
}
.createit {
font-family: 'Antic Slab', sans-serif;
font-weight: 500;
font-style: normal;
line-height: 100%;
letter-spacing: 0px;
font-size: 18px;
color: #5d2248;
}

and where I want the Style to be applied I have added:

<span class="ASSIGNEDNAME">text to styled</span>

or added the ASSIGNEDNAME (i.e. impress, magvatag or createit) in the custom CSS fields of the sections.

 

There has been no change within the theme with these styling cues. Is there something that I am missing that I must do with the style.less file in the child theme?

 

Thanks in advance

Keith

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Why do you have it repeated twice ?

 

@font-face {
font-family:"Champagne &amp; Limousines";
src:url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.eot?") format("eot"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.woff") format("woff"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.ttf") format("truetype"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.svg#Champagne&Limousines") format("svg");
font-weight:normal;
font-style:normal;
font-family:"Champagne &amp; Limousines";
src:url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.eot?") format("eot"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.woff") format("woff"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.ttf") format("truetype"),url("/wp-content/themes/MAGVA/fonts/Champagne/Champagne_Limousines.svg#Champagne&Limousines") format("svg");
font-weight:normal;
font-style:normal;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Keith Vaugh

the wows of cutting and pasting...

 

I managed to track the problems down however to a plugin that was causing issues with DMS...

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×