Jump to content

Archived

This topic is now archived and is closed to further replies.

21thirteen

Woocommerce Category Thumbnail not showing in DMS2

Recommended Posts

21thirteen

I have Woocommerce installed in DMS2 at http://jdh1.21thirteenhost.com/

 

Latest versions of DMS2 and WP and Woocommerce are installed and plugin are all updated.

 

When I upload a category thumbnail in Woocommerce/Products/Categories/Edit Category, it does not appear - please see:

 

http://jdh1.21thirteenhost.com/product-category/frozen-beverage-equip-syrup/frosty-factory/

 

I have custom CSS in the site with a few different "display:none" commands, but I've double checked by commenting each one out and still no-go.

 

The theme will let me use and display a description, but will not allow html in the description.

 

If anyone has an idea what I can do to fix this and/or to display an image on a category page by any means, I would appreciate it.

 

Thanks,

Perry

 

 

Share this post


Link to post
Share on other sites
Danny

Hi Perry,

 

You will need to use a child theme and add the following code:

 

http://docs.woothemes.com/document/woocommerce-display-category-image-on-category-archive/

 

Also, as far as I am aware you can not use HTML in a categories description, this is not theme related, this is related to WordPress.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Jessica McCabe Lawson
      By Jessica McCabe Lawson+
      I'm building a product catalog site. The featured image is set correctly, but the woocommerce placeholder image is displaying instead. If I click on the placeholder image, the featured image appears, and the featured image works fine as a thumbnail.
      Please view the site here: http://www.directmat.net/product/power-lock-logo-mat/
      Note: I deleted the placeholder image via FTP to see if that would inspire Quick Shop to look for the featured image. No such luck. Please help!
    • mtaus
      By mtaus+
      I'm using Woocommerce in a Pagelines framework. When I build out a product, I'm able to add images in the admin panel and the
      Product Image will display on Shop page, but neither the Product Image nor the Product Gallery will display on the product's dedicated page.
      Shop: https://bendbotanics.com/shop/
      Product Example: https://bendbotanics.com/product/500mg-full-spectrum-hemp-oil-fsho/
      Any help would be greatly appreciated!
    • cdracos
      By cdracos+
      Hello everyone,
      I face a common problem as I can see on relevant topics with quickshop plugin. 
      On Product Single page of woocommerce, i use quickshop as layout. The primary photo of my product doesn't appear on the thumb slider, but the first image is the default placeholder. 
      Need some help not with custom script in the product description for each product. 
      Have a look on my website: http://lillyandsid.gr/shop/camp-things-top/
    • bnapoli
      By bnapoli+
      I have Quickshop installed on my WooCommerce section of this website: http://a04.125.myftpupload.com/
      Main Shop: http://a04.125.myftpupload.com/?page_id=1198
      I've having what appears to be CSS issues on the individual product pages. After cleaning up any code accessible from the wp-admin, the page still appears broken. I never tried to customize it, it just came broken like this right out of the box.
      You can see examples of it broken on every single product page, see here:
      http://a04.125.myftpupload.com/?product=futaba-14sg-14-channel-2-4-ghz-radio-system
      http://a04.125.myftpupload.com/?product=gremsy-gstabi-h7-brushless-3-axis-gimbal
      http://a04.125.myftpupload.com/?product=dji-inspire-1-zenmuse-x5-gimbal-and-camera-unit
      http://a04.125.myftpupload.com/?product=dji-wookong-m-flight-controller
      Can somebody help?
    • King Creative Design
      By King Creative Design+
      I am setting up a Woocommerce site using PL Framework and Platform 5. I added a hook so the category description appears under the category page titles (on archive pages). However, it also appears under the title on the main "shop" page (which I have renamed "Catelog" page). There is a default description here and I can't figure out for the life of me where it is being generated from so I can change it. Any ideas how to change it or delete it on the main shop page ONLY? The staging site is here - http://16e.117.myftpupload.com/ and the page in question is http://16e.117.myftpupload.com/catalog/
      I have hit up Woocommerce support and they weren't familiar with Platform 5 and recommended I contact you.
      Your help would be appreciated, thanks!
      Michele

×