Jump to content

Archived

This topic is now archived and is closed to further replies.

dario

Page unintentionally redirects to Home

Recommended Posts

dario

I've created a DMS template named Articles.

I've created a page named Articles and have the page use the Articles DMS template.

The page URL is rcs/articles/

 

When I view the page, Articles, the home page appears instead.

The URL does not change but says rcs/articles, even though the content and the template being used is the Home page template.

The page name (at the top of the browser) shows Home - Site

 

When, on that page (URL, site/articles/), I load the Articles template, the page then looks as it should though the page title still shows Home.

 

When I then go to the actual home page, it displays with the proper URL and title but using the Articles template.

 

I'm running in no cache mode, have flushed LESS/CSS, on a local machine, browser cache off, etc.

I restarted MAMP and the browser a number of times and get the same results.

 

However, when I create a page named anything else and attach the Articles DMS template to it, all is well.

 

So, is the term articles reserved or something?

Share this post


Link to post
Share on other sites
dario

OK,

I think I've got this solved.

 

I had a CPT named blog and another named articles. For some reason this was really messing things up, including the redirect to the home page.

After removing the blog CPT and telling WP that my blog posts would be seen on the Articles page, all seems well.

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×