Jump to content


This topic is now archived and is closed to further replies.


Slow Site Respond Time

Recommended Posts


I'll start by saying that I've been down this road before and most likely know the answer, but it usually turns out in a massive round of finger pointing.


My client, who we launched a new site with in January on DMS 2 using a child theme, has had poor performance. She's on a VPS with Liquidweb and after a surge in traffic today (her average traffic is 25k visitors/day), the site pretty much went down (even after the host increased settings for performance). Liquidweb pointed their finger at the theme and that her site has too many http request happening.  (the site: http://foodiecrush.com).She emailed me, told me what LW said, and then proceeded to tell me she has had poor performance since we launched. 


Her site has total cache enabled (I can't disable it right now- this would most likely cause a complete crash in the site). This also means I can't currently enable debug (the setting won't save- caching blocks it). So I'm at a bit of a loss at what to do until the traffic slows and I can disable caching. (Which I know, having caching enabled and debug is no help). 


This isn't the first high-traffic client/hosting company I've heard this from and we've had one past client have their site custom built because they were repeatedly told it was DMS causing the slowdown. 


I know the answer I'll receive from you is 'it's not the theme' but I guess I'm just looking for more solid ground to stand on when I go back to the client. Any thoughts are appreciated. 





Share this post

Link to post
Share on other sites



We have no performance issues on our site, we receive a lot of traffic and our site is hosted by FlyWheel. As your client using a VPS, my suggestion would be to disable W3 Total Cache, (not sure why you say disabling this would cause the site to crash) and see the performance improves. It is likely that you haven't configured W3 Total cache correctly to match the servers environment. I would recommend removing it and replacing it with WP Super Cache and see if performance improves.

If it doesn't, then get away form that host and try someone like Linode or Digital Ocean.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

If you take a look at one of the pages - the homepage, for example - using a web page speed test tool, you'll find that there are many things you can do to speed things up.


Here are some of the more popular testing tools:








Here's another one that I like:




Run a few tests on one (or more) of the tools you like and follow the recommendations for speeding things up.


Generally, you'll find recommendations about caching, using a CDN, image optimization, number of page requests, and others - all of which can have a significant impact (especially when a site is in need of attention in these areas).

Share this post

Link to post
Share on other sites

Thank you for the answers. I've been down the road of disabling total cache for the exact reason statement but the client believes it helps (she's been told it helps and so she is resistant to believe me). 


I spent time yesterday using the speed page test and went with an array of answers: CDN, get rid of plug-ins, find someone to monitor the VPS, and attempt to reign in the advertising. 

Share this post

Link to post
Share on other sites

erin-wsk Hi Erin, so how did you resolve this issue?

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?