Jump to content

Archived

This topic is now archived and is closed to further replies.

bartoncollege

How to Check/Repair Site Search Field

Recommended Posts

bartoncollege

I have a site using Platform Pro 1.5.3 on WP 4.1.  After restoring the site following a hack and after upgrading to WP 4.1 and adding the Sucuri security plugin, I learned that the site search feature was no longer working.  After typing a search term and hitting Return, a completely blank page appears with the URL as "http://[sitename.tld]/?s=[search term]&submit.x=0&submit.y=0".  I'm not sure if it's an incompatibility with WP 4.1 or if it's the result of telling the Sucuri plugin to restore modified files.

 

Would someone offer tips on what to check or repair?  Thanks.

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you provide a link to the site in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
bartoncollege

The site is www.barton.edu.  The search field is in the upper right corner.  I have also discovered that /wp-admin/admin.php?page=pagelines now appears as a blank page, too.

Share this post


Link to post
Share on other sites

  • Similar Content

    • mtaus
      By mtaus+
      How can I remove the Search function from NavPro?
    • John Olsson
      By John Olsson+
      Hello, i'm working on a webshop, and got this code to really boost the search within WP. But when adding this code to functions.php the front end media library search flipped totally, and not working at all, any ideas what's the problem?
      function atom_search_where($where){ global $wpdb; if (is_search()) $where .= "OR (t.name LIKE '%".get_search_query()."%' AND {$wpdb->posts}.post_status = 'publish')"; return $where; } function atom_search_join($join){ global $wpdb; if (is_search()) $join .= "LEFT JOIN {$wpdb->term_relationships} tr ON {$wpdb->posts}.ID = tr.object_id INNER JOIN {$wpdb->term_taxonomy} tt ON tt.term_taxonomy_id=tr.term_taxonomy_id INNER JOIN {$wpdb->terms} t ON t.term_id = tt.term_id"; return $join; } function atom_search_groupby($groupby){ global $wpdb; // we need to group on post ID $groupby_id = "{$wpdb->posts}.ID"; if(!is_search() || strpos($groupby, $groupby_id) !== false) return $groupby; // groupby was empty, use ours if(!strlen(trim($groupby))) return $groupby_id; // wasn't empty, append ours return $groupby.", ".$groupby_id; } add_filter('posts_where','atom_search_where'); add_filter('posts_join', 'atom_search_join'); add_filter('posts_groupby', 'atom_search_groupby');  
    • Queue-it
      By Queue-it+
      HI,
      Search function doesn't seem to work. 
      When ever searching for something it redirect to the home page and add the search string to the url.
      For example searching for "cases" it would display https://queue-it.com/?s=cases
      Do you know how to solve that? 
    • MissT
      By MissT+
      Would be great to have the ability to include a search option within menus and within Splashup - is this possible?
    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
×