Jump to content

Archived

This topic is now archived and is closed to further replies.

Ryan Logan

Custom CSS Not Saving

Recommended Posts

Ryan Logan

This has reared it's ugly head again.  I've experienced this in the past and the only new variable this time is Flywheel hosting. The Custom CSS I've entered is extremely basic and is not producing any errors.

 

I had a lengthy conversation with Flywheel before posting this and they are familiar with DMS and Pagelines.  As we speak, they are trying to reproduce this issue on their end.  Flywheel has confirmed that caching has been turned off, as requested earlier today.

 

www.fall-linemotorsports.com  **This site is hosted on Flywheel and is not live (password-protected).  I'll PM the credentials if needed.

 

-Disabled ALL plugins (they are enabled at the moment)

-Cleared browser cache

-No caching turned on (Flywheel has disabled caching as requested)

 

Update 1:  Also, I have CSS Hero installed. As mentioned, disabling it does no good.  Just thought that was worth mentioning.

 

Update 2:  If you look under the "About" section on the landing page, using Chrome...you'll notice bold text.  The bold text does NOT show up in IE or in Firefox.  Why?

 

Ryan

Share this post


Link to post
Share on other sites
Danny

Hi,

 

What site are you referring to as the site you have linked doesn't even appear to be using DMS ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Can you send me a PM with the htaccess username/password so I can access the site please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Guest

From Flywheel...

 

"The following is a PHP fatal error that we noticed while investigating:

 

Fatal error: Call to undefined function dms_suggest_plugin() in /flywheel/base/mounts/14877/www/wp-content/themes/dms/functions.php on line 11

 

 

We commented the line out in the functions.php and saving the CSS seemed to work. If you look in the custom CSS section of DMS you can see a line of that we wrote to test this.  Not sure what would have happened to that functions.php but that is what was holding back those changes."

 

Here is the line from the DMS functions.php that Flywheel is referring to:

 

/*dms_suggest_plugin( 'Contact Form 7', 'contact-form-7', 'Contact Form 7 can manage multiple contact forms, plus you can customize the form and the mail contents flexibly with simple markup.<br />The form supports Ajax-powered submitting, CAPTCHA, Akismet spam filtering and so on.' );
*/
 
This is interesting because this is a brand new install of DMS and I've been using a DMS Child Theme (Skeleton) from the very start.
 
Update:  Even with Flywheel's attempts mentioned here...the issue still persists.  This is not solved in other words.

Share this post


Link to post
Share on other sites
Danny

I have just this moment logged in and added the following:

 

.danny-test { color: #428BCA; }

 

I have then refreshed and the CSS is there when the site reloads? Is this now resolved ? Also, not sure regarding that fatal error, as I am not seeing that on my test sites. I will speak to our developers regarding that issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Guest
I'm extremely happy to report that I figured out the fix. After doing numerous tweaks with Chrome (uninstalls, reinstalls, using older versions, using off-line installers, disabling extensions,etc.), The fix was to reset Chrome to its default settings. Hopefully this helps someone else should they run across this issue.

Share this post


Link to post
Share on other sites
Danny

Are you aware of what setting was causing the issue ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Guest
The only thing I can think of is that it was one of the Chrome extensions. The issue persisted in any workstation where I signed into Chrome with my profile.

I will post back here if I figure out the extension causing the issue.

Share this post


Link to post
Share on other sites
Guest

Update:  

 

I ran into this again and my previous fix (reset Chrome back to defaults) did not work.  I've finally found something that works for me 100% of the time.  After you enter something into the Custom LESS/CSS section, click the Custom Scripts button. This will, for some reason, tell DMS that a change has been made (turning the publish/undo indicator from GREEN to BLUE).  Click Publish and the Custom CSS will be saved.

 

Unless I do the steps above, the publish/undo (or whatever it's called) indicator always remains Green.  I've posted about this before.  I'm thinking there has to be something to DMS not knowing when something has been changed or at least something of significance.  I've disabled all plugins and cleared out all Custom CSS. So, I don't see how this could be my code or my plugins.

 

Ryan

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×