Jump to content


This topic is now archived and is closed to further replies.


Pagelines Pro - PageLines Lazyload causing a hidden image to be displayed unnecassarily...

Recommended Posts


Required info.

URL: https://onespiritinc.com/register/nlp-cloud-practitioners/

WordPress Version: 4.1

DMS Version:

Server/Host: Hostgator

Debug Mode: Enabled


Active Plugins in Use: 

Akismet Version: 3.0.4

DMS Professional Tools Version:1.8.5

DMS Snow Version 1.0

Enable Multi-site Version 1.5

Eye Only: USer Access Short Code Version 1.8.2 

Hooker Version 1.5

JW Player 6 Plugin for Wordpress Version 2.1.10

LearnDash LMS Version

MemberPress Business Edition Version 1.1.7

NO Right Click Images Plugin  Version 2.5

Optimize Database after Deleting Revision Version 3.1

PageLines DMS Force SSL/HTTPS Version 1.2

PageLines Updater Version 1.2.6

Plugin Organizer Version 5.7.6

Poppy Version 1.4

RMTP Streaming Video Player VErsion 2.4

Salebar Version 2.0.2

SSL Insecure Content Fixer Version1.8.0

Teammate Version 1.3

VoucherPress Version 1.5.4

Wordpress Importer Version 0.6.1

WordPress MU Domain Mapping Version

WordPress SEO Version 1.7.1

Magic Action Box Version 2.15.5

Q2W3 Fixed Widget Version 4.0.6

iframe Version 3.0

Easy FancyBox Version 1.5.7

Search & Replace Version 2.7.0

Custom Sidebars Version

Jetpack for Word Press.com Version 3.3

PluginBuddy S3 URLs Version 0.1.0


Hi there,


I'm having a conflict with Pagelines Pro - PageLines Lazyload option checked that is causing a hidden image for a Member Press product page to bug out. The image is only suppose to display when someone clicks a Sign Up  button to indicate the form they filled is being processed.


I contacted the developer of MemberPress and he helped me narrow the problem down to lazy loading.


So I deselected it in Pagelines Pro to test and sure enough the error doesn't occur when deselected.


The problem is that now my whole site has to suffer as a result.


I asked the developer of Member Press if there was a work around and he said:



There are a handful of ways to implement lazy loading, so I think you'll need to contact your theme author about this one and see if there's a way to disable lazy loading on the product pages, or on specific images.


Really, there seems to be a bug in their code -- I would think the lazy loading script should be fixed to not show images that were already set to hidden.


So here I am contacting support to see if there is a way to do exactly that.


You can view the issue yourself at this page:




Notice how the signup working image keeps spinning even before clicked and as soon as the page loads.


Is this a bug in PageLine Lazy Load?


Is there a work around?


or should I try another Lazy Load plugin.


Any suggestions?







Share this post

Link to post
Share on other sites



The DMS Pro Tools Lazy load option has basic lazy load functionality. Therefore, I would recommend you try another lazy load plugin and see if this encounters the same issue.


This plugin is a good one - https://wordpress.org/plugins/bj-lazy-load/

If that plugin too, also causes the error, then you will need to contact the Member pass team again and say this is isolated to PageLines only, but other lazy load plugins too. 

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

Hi Danny,


Thanks for the great recommendation bj-lazy-load solved the problem quickly right out of the box.


I did also noticed in the settings that it allows "skip images with certain classes" so that would have worked too if default didn't.


Much appreciated!

Share this post

Link to post
Share on other sites

No problem.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?