Jump to content

Archived

This topic is now archived and is closed to further replies.

anislagan

Custom CSS query

Recommended Posts

anislagan

Is there a way to copy automatically the existing Custom CSS applied to a Custom components that are newly added to the page?

 

It's tedious to copy all the Custom CSS (applied to Custom component) to a newly detached component.

Share this post


Link to post
Share on other sites
jmad

I'm not sure exactly what you are asking but if you have a text box and want another to have the exact same classes from the custom class section.  Can't you just clone the item?

Share this post


Link to post
Share on other sites
anislagan

Yeah. It's probably a bad practice on my part. 

 

I saved a section as as custom component that has cusom CSS applied specific elements id.

 

So when a re-used a custom component elsewhere and try to detach, DMS generates new set of ID's. Hence, all the CSS applied to Custom component no longer applies to the re-used component.

 

A better workaround is to avoid saving custom sections that has custom css applied to element ids.

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You should not use IDs to target elements, you should always use classes if possible. Therefore, if you want to apply custom CSS to a custom section you have created and saved and use that on other templates which you have detached. The best course of action is to not use the ID for the reasons I mentioned above and instead use the style classes field.

Apply your custom class to that section and then use that class to add your own styling. This way, when you use your saved section on a new template and detach it, all you need to do is apply that custom class again.

 

Again, never use IDs unless there is no alternative.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×