Jump to content

Archived

This topic is now archived and is closed to further replies.

evscicats

Can't get filter to remove <br> before <input> tag

Recommended Posts

evscicats

I am trying to remove a <br> tag that is appearing before a submit button on my website.  The reason I want to get rid of the break is because the button is not staying perfectly inline with the select menus.  Here's the link to the custom taxonomy page where I'm having the issue.  http://evscicats.com/blog/content_area/world-history/

 

I have tried the following filter in my child theme functions.php file but it doesn't work.  Maybe I'm not calling the right hook?  

 

Any help is greatly appreciated!

add_filter('pagelines_page', 'remove_bad_br_tags');
function remove_bad_br_tags($content) {
	$content = str_replace('<br /><input', '<input', $content);
	return $content;
}

Thanks,

 

Jerrad

Share this post


Link to post
Share on other sites
Simon

How are you adding the submit button?

Share this post


Link to post
Share on other sites
evscicats

To generate the select menus, search box and buttons, I'm using a plugin called "Search & Filter".  I put all my coding for the plugin in a DMS TextBox section.  Here's the code I used in case you want to test.

[row][span8]<h3>Resource Filter</h3>[searchandfilter fields="content_area,lesson_type,grade_level" headings="Content Area,Lesson Type,Grade Level" submit_label="Filter"][/span8][span4]<h3>Keyword Search</h3>[searchandfilter fields="search" search_placeholder="Search..." submit_label="Submit"][/span4][/row]

Thanks!

 

Jerrad

Share this post


Link to post
Share on other sites
Danny

Try adding your shortcode to the NextBox section. If that doesn't work, you will need to speak to the author of that Search/Filter plugin.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
evscicats

I decided to go ahead and use the plugin in the sidebar.  I didn't get anywhere with contacting the author.  Thanks for your help!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×