Jump to content

Archived

This topic is now archived and is closed to further replies.

atcdomainsolutions

CSS Suddenly not applying to website

Recommended Posts

atcdomainsolutions

I have been building a site for a couple of weeks.  We are near the end and when I wake up today, none of my CSS is taking effect like it has been all this time.  I have not added any new plugins that haven't been there since day 1 and the one plugin that had an update yesterday, I disabled thinking that was the culprit (was a social plugin) but no.  I have checked my Text Boxes and areas where I have custom classes that connect to the CSS in the Less box and they are all still there but it's truly just all of a sudden, NONE of my Custom CSS is having any effect.  

 

I even (few min ago) deactivated ALL plugins and it's still not reading my CSS.  Need help here since today was the day I was going to turn the site over to the client.  Have never had this happen.

 

Can supply domain and sign in details once a moderator responds.

 

Thanks.

 

James

Share this post


Link to post
Share on other sites
Simon

Hi James, you can add your site to your private support url field in your profile, only mods can see it. People still put company websites there though \o/

 

CSS does not change by itself overnight ;)

 

If you do not want to give the URL away, at least paste the custom less/css into a pastebin so we can take a look at it.

Share this post


Link to post
Share on other sites
atcdomainsolutions

Hi James, you can add your site to your private support url field in your profile, only mods can see it. People still put company websites there though \o/

 

CSS does not change by itself overnight ;)

 

If you do not want to give the URL away, at least paste the custom less/css into a pastebin so we can take a look at it.

Simon

 

I actually figured out what a big chunk of it was.  

 

IN the DMS editor, I added the Google Font "Oswald" so I could use it across the site and Yellowtail...this is what I had:

 

 

Yellowtail|Oswald:400 | Yellowtail|Oswald:300

 

Well, overnight (seriously,NOTHING was done to the site), I wake up and all my formatting looked really off but found out the font was not being applied that I added throughout my site and that's when (after deactivating plugins, etc etc), I noticed that line of Google font code was no longer in the DMS "Extra Google Fonts" area...readded it and it applied the styles so I guess you can say the problem is fixed but I am the only one with access to the editor and it truly just disappeared.

 

James

Share this post


Link to post
Share on other sites
aldisney

I've noticed that, on multiple occasions, I have to publish CSS twice in order for it to take, and sometimes more; this seems to be more consistent when I've got more extensive CSS customizations. One thing you might try (rather than just using the built-in options) is keeping a separate stylesheet on your local machine. On two or three occasions, I've had large chunks (like, seriously, lines and lines) mysteriously disappear from my custom CSS. Keeping a local version handy makes for a pretty quick and easy fix. Just my two cents, from a user standpoint.

Share this post


Link to post
Share on other sites
kristarobyn

This happened to me today. I'm still awaiting a response. Weird.

Share this post


Link to post
Share on other sites
Danny

@kristarobyn† - Please keep your responses to your own topic, which I have replied to. I am unable to see any issue with that sites CSS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×