Jump to content

Archived

This topic is now archived and is closed to further replies.

scswraps

Server Crash

Recommended Posts

scswraps

Hello,

 

I am having some issues with my Pagelines install crashing our server. The memory is being maxed out when the site is active and I can only assume it's one of the activated features.  I have a DV at Media Temple with plenty of horsepower and the Support them there feels there is a "run away" script ca

Share this post


Link to post
Share on other sites
Simon

IM afraid you are going to need to provide a little more information. Like a URL to the site in question, the private support url in your profile isnt even a wordpress site so im guessing it isnt that one.

Can you please explain what a 'DV' is as well.

Share this post


Link to post
Share on other sites
scswraps

Oh wow, that posted~!  I was mid type when it must have sent.

 

So, let me compete my ramblings....

Share this post


Link to post
Share on other sites
scswraps

I have activated the site now for troubleshooting. DV is a Dedicated Virtual Plan at Media Temple.  The graph above is constantly maxed out unless I deactivate the site in questions subscription. 

 

http://bznblog.com

Any help is greatly appreciated, 

Share this post


Link to post
Share on other sites
Simon

Im sorry, deactivate the sites subscription? What does that mean?

 

The site loads pretty fast, I cant see what would be causing high memory usage like that.

 

The sales page on media temple said that package was fully managed, is that right? If thats the case the server admin will have more information via the logs or control panel.

Share this post


Link to post
Share on other sites
scswraps

Im sorry, deactivate the sites subscription? What does that mean?

 

The site loads pretty fast, I cant see what would be causing high memory usage like that.

 

The sales page on media temple said that package was fully managed, is that right? If thats the case the server admin will have more information via the logs or control panel.

 

I turn off the web hosting and my server returns to normal, after leaving the site active for a short period (1hr - 1 day), the server begins to hit it's limits again. I'll post another graph and then you might see where things are running slow again.

Thank you

Share this post


Link to post
Share on other sites
Simon

Are you the server admin or does somebody else do it for you?

Who set the VPS up?

How is PHP configured?

Is the database server setup properly?

 

A graph isn't going to help really, you already showed us a graph in the opening post.

What the graph doesn't show is *what* is causing the spike, whether its PHP running away, or a page being refreshed over and over.

 

The only way to get that information is from the server itself.

 

Ask your admin to simply provide some basic info when the spike occurs:

  • What process is using too much memory (php/apache/nginx/ftp/mysql) etc?
  • How many requests are being served?
  • Is the database server configured properly?

Share this post


Link to post
Share on other sites
scswraps

I setup and configured everything. Please find an SSH top view of the current server processes while running smoothly. The moment I experience another lag I'll take another screen and post. To my knowledge, the PHP and DB is configured correctly. I can provide anything else needed to troubleshoot including FTP or WP-admin access. 

 

Best, 

Share this post


Link to post
Share on other sites
scswraps

Plesk actually  

Share this post


Link to post
Share on other sites
Simon

Oh really? Im afraid I've never had the pleasure of Plesk.

 

Well next time it goes haywire, be sure to check the apache logs to see if the problem is excessive connections.

 

How many users does your site have when the load goes high? 

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×