Jump to content

Archived

This topic is now archived and is closed to further replies.

jmad

MultiMenu - Use on Front and Interior Pages

Recommended Posts

jmad

I probably haven't played around with this enough but hoping someone else has and can advise.  I would like to use MultiMenu on a homepage with a background image and have a column and media box contained there.  This is simple enough but I also want to use MultiMenu on interior pages so I keep the same menu effect (just add a background color and no image).

 

I tried using MultiMenu in both the header and Template Areas and hiding the Header section on the home page but the MultiMenu still visible on the homepage won't respond.  

 

How do you go about using MultiMenu on all pages but not having the same background images or elements?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You will want to use the section in the Template area and then use different templates for using different colors. Another alternative would be to just use custom CSS and the page id class.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad

Not sure I was clear or at least I don't understand the answer.  

 

I want to use the Multimenu on all the site but on the homepage I want a large image in the Multimenu area as background and then it will hold a media box and text box.  On all the other pages I simply want it to be a color with the logo in the top left or possibly center.

Share this post


Link to post
Share on other sites
Danny

If you want to achieve that you will need to use custom CSS, like I mentioned above. If you want to have the section house different sections on different pages, you will need to use the MultiMenu section in the Template region like I also mentioned above.

If you use position MultiMenu in the template area you will be able to configure it different on a template by template basis. If you use it in the Header region, this will not be possible.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad

So MultiMenu is made more for a single page layout? 

 

Share this post


Link to post
Share on other sites
Danny

No, like all sections it can be used in anyway you see fit. However, as the section is usually going to be housed in the Header region as it is a navigation section, it can therefore, not be unique on a page by page basis. As the Header region is a global region and not something that can be configured on a page by page basis. That is why, I am suggesting placing it in the Template region and use templates. That way you can configure it differently.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad

I understand how the Fixed, Header, and Template sections work.  I'm not sure I see the function of MultiMenu and how that will work through a site.  I'll play around with it. 

Share this post


Link to post
Share on other sites
marcogiunta

I am having the same problem with MultiMenu.... i am just trying to achieve the demo implementation... 

Share this post


Link to post
Share on other sites
illinimatt81

I am trying to add it as well and it says to refresh the page to display and nothing...

 

I'm sure some setting is off.

 

I am creating a "new" home page and adding this in the template section full width and plan to keep my existing Nav for the rest of the site.

Share this post


Link to post
Share on other sites
communicreations

Try creating a new menu in WP Appearance, then under "Manage Locations" tab assign it to mobile navigation.

Share this post


Link to post
Share on other sites
Danny

Are you saying you want to have the MultiMenu on one particular page configured with a specific WordPress menu and then have the rest of your pages not use the MultiMenu ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad

Not sure about the rest but for what I was asking.  

 

Multi-Menu on all pages of site so the menu experience is consistent.  On the homepage MultiMenu with a large background image and a media box and text box over the section.  On the remaining pages MultiMenu without an image but just a color.  

 

Adding MultiMenu to the template area of the homepage and creating a Template from that then going to an interior page, applying the default Template and adding MultiMenu in the template area works.   

Share this post


Link to post
Share on other sites
marcogiunta

i am trying to active the same thing as the demo.... on my site it looks terrible

Share this post


Link to post
Share on other sites
marcogiunta

i am adding MultiMenu to the fixed portion of the template where the menu usually sits

Share this post


Link to post
Share on other sites
Danny

@marcogiunta† - If you're going to use the MultiMenu section, you first need to disable the Fixed region in your settings. The MultiMenu section settings inform you of this.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
marcogiunta

Where does it inform me? 

 

Do i put it in header?

Share this post


Link to post
Share on other sites
marcogiunta

i put it in the header ... but it still does not work right... do we have documentation with Multimenu?... Thanks for the help Danny 

Share this post


Link to post
Share on other sites
Danny

marcogiunta - How have you installed the section, as your CSS isn't loading. Which leads me to believe that the section has been installed correctly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
marcogiunta

downloaded the plugin from pageline.... then uploaded the zip from the plugin tab on word press

Share this post


Link to post
Share on other sites
jmad

I had this issue with the first release of Multi but there was an update.  Did you download the file recently?

Share this post


Link to post
Share on other sites
marcogiunta

i only see Ver 1.0

Share this post


Link to post
Share on other sites
marcogiunta

deleted all files and reinstalled .... works

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×