Jump to content

Archived

This topic is now archived and is closed to further replies.

mwest

Post Formatting

Recommended Posts

mwest

Trying to figure out line breaks in posts... <p> and/or <br> tags are being stripped and it is making the post format look funny. I am trying to get each numbered section to fall under the number above. See the following link for the current experience. http://deluge.media/bests/top-10-books-of-2014/

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The reason as to why your numeric values are not being position below on another and aligned vertically, is because you have used a class on your image that is using the CSS property float and the value left. When you use floats, you need to make sure that you clear it so that content below is positioned correctly. This is basic CSS positioning and therefore, I recommend you read through the CSS guide on W3Schools.

 

To resolve your position problem, you're either going to need to change the layout or after every </li> include the following <div class="clear"></div>

 

So your code will need to look like this:

 

<ol>

<li>....</li>

<div class="clear"></div>

<li>...</li>

<div class="clear"></div>

<li>...</li>

<div class="clear"></div>

</ol>

 

Also, please be aware that your issue was caused by your HTML and use of CSS, in future you will need to either ask your question on the WordPress support forums or a HTML/CSS specific forum for support. As we can not provide assistance to users with errors from their own HTML or CSS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • bjs198
      By bjs198
      Hey team,
       
      I've set a global <p> style in the custom scripts box using code from google fonts which works great, however I'd now like to use a additional google font style with a couple of small text sections. When I try to style the specific text box using the Inline CSS Styling field I find it doesn't work and reverts to the global style.
       
      Am I doing something wrong or can you not override the global text style?
       
      ^ sorry bold, no idea why I can't get rid of it :)
       
      Cheers
       
      Barney
×