Jump to content

Archived

This topic is now archived and is closed to further replies.

stoltz

Sections become nested or disappear upon save in DMS 2 - bug?

Recommended Posts

stoltz

When I drag and drop sections in DMS 2, they sometimes become nested upon refresh and then they disappear when I save changes to the template I am working on.

 

When I put out a two column section and fill the sections with textboxes one column (automatically) ends up inside another. The same thing happens when I am putting out a media box and other sections on top of that, the media box expands on top of the other sections upon refresh so it becomes impossible to select them. When dragging the expanded media box back below the other sections, then it snaps back to place - until refresh when it pops back into on top of the other sections again.

 

If I save a template with "expanded" section, then the expanded section disappear upon save.

 

It doesn't matter if I create new templates or work with old ones - Same bug.

 

I am using latest Wordpress and working in Chrome on a Mac with latest version of OS and browser.

I also have the latest version of DMS 2.

Share this post


Link to post
Share on other sites
stoltz

I might have found something that might be causing the problem.

 

I am adding this inside a textbox to show a specific button look and this causes the section to havoc

 

<a class="podsubscribe button2" href="#"><font color="#BB3333"><i class="podicon icon-apple "></i> Itunes</a>

 

Is this the cause and if it is, how do I apply classes lets say to a text?

Share this post


Link to post
Share on other sites
Aires

Hi stoltz

 

give this a try

 

<a href="#" class="your class here">text here</a>

 

your class is in the wrong place

 

~Aires


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
stoltz

Aires

 

I discovered that DMS 2 sections are really sensitive to non-closed tags. I closed the font tag and behold, all the strange things with sections that moved around came to a halt. I still have my class where it originally was and that still works. Two days of hair pulling agony is over ;-)

 

Lesson learned: Don't be sloppy with closing the tags in sections as it messes up DMS 2.

 

Thanks for you help

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You shouldn't even use the font tag, as it is not support in HTML5, you should just use CSS instead.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
stoltz

Danny

 

How do I target the text in a textbox with CSS - by styling the P-tag?

 

I have a textbox which has a border styled through CSS. I want the text inside that textbox to be red, but when I used inline CSS in the section settings it made the border also red. The way I did it now is using the font tag inside the text.

Share this post


Link to post
Share on other sites
Danny

If you want all the text in a TextBox to be red, use the class or tag for the text in your CSS.

 

Such as:

 

.section-textbox p {
  color: red;
}
 
You can also use the Sections unique ID so that the styling only applies to that TextBox, the section ID can be found by inspecting the section and the ID will appear in between the ID tag.

For example:

<section id="textbox12345">
 
So we can use that ID in the CSS to target that particular TextBox like so:
 
#textbox12345 p {
  color: red;
}
 

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • mrhinsh
      By mrhinsh+
      I have found that many of the components, especially lists, do not work in the Edge browser. 
      For example https://nkdagility.com/ has 6 video boxes that only render in Chrome and do not show in Edge.
    • bnapoli
      By bnapoli+
      On my site www.modishmel.com I'm seeing the "blog post title" within the "pins" plugin section breaking words into multiple lines. See screenshot attached.
      Only seeing it in Firefox. Can you help?

    • Jared Smith
      By Jared Smith+
      I haven't figured out how to get the "Sync Loaded Item" option in templates menu of Platform 5 to stay checked. It doesn't give me an option to save settings when I select it, and when I select it then click off the editor, it unselects. Also if I select it before loading a template, it doesn't stay checked there either.  Whats going on?
    • Simon
      By Simon
      WordPress 4.7.1 was released on 11th January.
      It introduced a new bug that stops certain filetypes from being uploaded.
      This bug unfortunately stops users from uploading SVGs with the Platform 5 builder.
      In the meantime if you need to upload an SVG or have any other image upload issues then please try this plugin that bypasses the mime checks that were introduced.
      https://wordpress.org/plugins/disable-real-mime-check/
       
      Link to trac ticket: https://core.trac.wordpress.org/ticket/39550
      EDIT: 4.7.2 has been released without the fix. Fix is now slated for 4.7.3
    • mrhinsh
      By mrhinsh+
      Guys,
       The ProPricing plugin does not seam to render shortcodes.

       
      I am using WP-Types, and as you can see the shortcode is rendered in the "Elements" but not in the "ProPricing".
      Can we get a fix?
×