Jump to content

Archived

This topic is now archived and is closed to further replies.

dario

Targeting icons in the Sociallinks Section

Recommended Posts

dario

I'm trying to target the icons in the Social Links section so that I can change their color on hover, like they do automatically in the ShareBar section.

 

Default seems to be the site's link base color.

 

I've tried all the permutations I can think of or see via Inspect Element. No luck.

 

My latest:

#site .sl-link .icon-google-plus:hover {
	color: #d34836;
}

Which is clearly way off!

 

The other, failed avenue was to add the Google Plus icon/functions to the ShareBar via an Action Hook but I got nowhere with that. Too bad too because the way those icons animated down was cool.

 

Anyway, what am I missing here guys?

Share this post


Link to post
Share on other sites
Aires

Hi, dario

 

Give this a try

 

a.sl-link:hover {
    color:yellow;
 
~Aires

ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
dario

Cool. Thanks Aries. You pushed me the right direction.

For anyone else who wants to do this, I made the social links black. Then, on hover, colored them to their respective guidelines:

/* Changing ShareBar and SocialLinks icons to black */
.pl-social-counter .pl-social-icon i {
	color: #000000;
}

/* Changing the SocialLinks hover to their guide colors */
a.sl-link .icon-facebook:hover {
	color: #3b5998;
}

a.sl-link .icon-twitter:hover {
	color: #55acee;
}

a.sl-link .icon-google-plus:hover {
	color: #d34836;
}

a.sl-link .icon-pinterest:hover {
	color: #cb2027;
}

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×