Jump to content

Archived

This topic is now archived and is closed to further replies.

carlo

DMS2+WPML: 404 blank page in other languages

Recommended Posts

carlo

Hallo,

we have sites builds with dms2 + wpml plugin for translation, in italian as main language (set as domain site), and english, french, german, etc. translations (set in subdirectory).

We discover this issue with 404 pages (wich uses "nopost" section) on other languages:

the "nopost" section function as needed for the main language ( example: http://www.hotelbaiadinora.com/sdghsrthrt) but gives a blank page in other languages (example: http://www.hotelbaiadinora.com/en/sdghsrthrt ).

where is the problem? Can you help us to solve this?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you configure WP_DEBUG to true in wp-config.php file and see if any error is printed to screen please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
carlo

There are only two notices:

[15-Dec-2014 11:35:30 UTC] PHP Notice:  Undefined index: missing in [...]/wp-content/themes/nicks-base-theme-master/functions/language.php on line 204
[15-Dec-2014 11:35:37 UTC] PHP Notice:  Trying to get property of non-object in [...]/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 7159

 

 

Share this post


Link to post
Share on other sites
Danny

You appear to be using Nicks child theme which is no longer supported by the developer and therefore, you should be using the PL Starter theme or my Skeleton child theme instead.

 

Also, Nicks base theme doesn't include a language.php file by default. Therefore, this must be something you have added yourself. We can not provide assistance to users who have encountered issues or errors which files they have included themselves.

 

You can get more information on using the PL Starter theme here - http://answers.pagelines.com/how-to-install-a-child-theme

You can also download my Skeleton child theme here - http://dannyholt.github.io/skeleton/

 

Once you have either the PL Starter theme or my Skeleton theme installed and active, see if the same errors are printed.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
    • jagipson
      By jagipson+
      404 When trying to connect site to PL

    • mrhinsh
      By mrhinsh+
      I am trying to get WPML working on my Pagelines instance. I am interested in getting help from anyone that has tried, especially @claudedagenais who seams to have it working.
      My issues are:
      How to translate header and footer How to get the menu to show all nav even if not translated How to get non-translated posts /pages to show up when only in default language - true for Masonry, Newsfront, and other list showing items... I have zero skills in PHP and its my site for my company. 
      note: Multi-lingual is a business decision and is required. I have vetted all of the multi-lingual options and the only one fit for purpose is WPML. 
    • JP
      By JP+
      Hello,
      How can you set the translations with platform5, the parts that are not in pages or posts? Texts and images…
    • StuLeeUK
      By StuLeeUK+
      Can anyone help me figure out why I currently get a blank page approximately 50% of the time when viewing my site.
      I'm a complete amateur - I only use Pagelines/PL5 to create sites for my own projects - so it might seem like an obvious thing to everyone else but I don't know where to start and just hoping someone can point me in the right direction please.
      I've attached a screenshot showing what the page should like (left side) and what I actually see (right side) quite often and it wont display unless I refresh the page.

×