Jump to content

Archived

This topic is now archived and is closed to further replies.

pazyluz

fixed navbar: change size and color of menu item letters

Recommended Posts

pazyluz

Hi folks, this is a longstanding unanswered question. I am either unable to find the correct selector or there is another reason why I cant change the size or color of menu items and search bar in the fixed nav. I need to change them to white or make the font bigger because they can barely be seen. Here is the code given me by the theme designer (which didn't work either): 

 

"Here is the code you need for the navbar:

.navbar.pl-color-base .navline > li > a {
color: rgba(135,174,17,1);
text-shadow: none;
transition: all 0.1s linear 0s;
}  "

Below is all the code I have pasted in regarding the fixed nav.
 
.navbar.pl-color-black-trans {
background: #330033;
border-top: 1px solid rgba(0,0,0,0.99);
}
.navbar. {
  border-top: 1px solid #330033;
  background-color: #330033;
  border-top: 1px solid #330033;
}
.navbar .plbrand {
  float:left;
  margin:0 2% 0 0;
  padding:0 1%;
  font-weight: 400
}
 
.navbar.pl-color-base .navline > li:hover > a, .navbar.pl-color-base .navline > li.current-menu-item > a, .navbar.pl-color-base .navline > li.dropdown.open > a {
    background-color: #330033;
    box-shadow: 0 -4px 0 #87AE11 inset;
    color: #87AE11;
}
.navbar.pl-color-base .navline > li > a {
    color: rgba(135, 174, 17, 0.6);
    text-shadow: none;
    transition: all 0.1s linear 0s;
}
.navbar .navline > li.current-menu-item > a {
    background-color: rgba(0, 0, 0, 0.1);
    color: #FFFFFF;
    text-decoration: none;
}
.navbar .navline > li > a {
    color: rgba(255, 255, 255, 0.8);
    display: block;
    float: none;
    line-height: 19px;
    padding: 9px 12px;
    text-decoration: none;
    text-shadow: 0 -1px 0 rgba(0, 0, 0, 0.25);
}
.my-title-1 {
font-color: #330033 !important;
}
.page-id-77  .pl-imageframe img, img.pl-imageframe {
background-color: #FFFFF;
border: none;
}
 
 
Again, I need to change either font or size or both to make the menu items in the fixed nav more visible. Thanks for any help. Screenshot attached. Nope, guess not.  Last question:  why am I getting this "You have exceeded your allotted disk space for attachments"  You can see my fixed nav on my site

Share this post


Link to post
Share on other sites
Aires

pazyluz Can we have a link to your site.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Danny

You have already posted the selectors to target the nav links, you just need to use the #site or section ID to prefix your code. For example:

 

#site .navbar.pl-color-base .navline > li > a {
  color: white;
}
 
You can also add font-size: 40px; to the code above or whatever value you like.
 
To change the search field use the following code:
 
#site .navbar .searchfield {
background-color: #fff;
}
 
If you have a designer, he/she should realise that the code you're adding is not being used and the default CSS of DMS is being used instead. They can see this by using Chrome dev tools. That is why if you wish to override the default CSS you can either use #site or the section ID to prefix your code, like I have done above.

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
×