Jump to content

Archived

This topic is now archived and is closed to further replies.

vladimirtrajkovic

Hover News Skews my website to the left

Recommended Posts

vladimirtrajkovic

Dears,

 

Recently I have bought Hover News plugin, but ever since I installed I have a trouble with my website. Namely, no matter how I setup the plugin (i.e. Grid or Row Closed format, number of rows and posts, full widith or content widith, post loading method etc.) my whole website is skewed to the left. All content, pictures, navbar are moved to the left so I do not see the left, lets say, 1/15th of the site. I am sending you attach file where you can see a printscreen of the problem.

 

I hope that you can provide remedy to the problem.

 

Regards,

Vladimir

Share this post


Link to post
Share on other sites
Gavin_

Hello, 

 

First of all thanks for your purchase. 

Could you please provide a link to your site so that we can have a look?

- thanks

Share this post


Link to post
Share on other sites
vladimirtrajkovic

Hi there,

 

You can find my website on the following link https://htechnews.com. I hae another question: I keep my post pictures on Cloudinary. So how can I make Hover News to call pictures from the secure link i.e. https://res-cloudinary and not from http://res-cloudinary? If you check my website on whynopadlock.com you will see that all of the 15 pictures that are called from Hover News are called from non-secure link.

 

Please advise if I have to post this as a new forum topic.

 

Regards,

Vladimir

Share this post


Link to post
Share on other sites
Gavin_

Thanks for the link. 

For the page alignment we cannot see what is causing the issue. When you disable Hover News does the issue go away?

As you can see here there are three grid rows - which is probably not required. Also the width of the page will be determined by the pl nested section - you can increase or decrease as required.  http://screencast.com/t/Z9OMFOFoyo

 

Currently Hover News is designed to use the Featured Image of the post and is not designed to use external images. 

Share this post


Link to post
Share on other sites
vladimirtrajkovic

Yes, the issue with the alignment goes away if I remove Hover News.

 

Now for the hard part: I am not a programmer and I am not familiarized with the coding, so I will search the internet in order to find out how to increase and decrease the pl-nested-section. However, before I start digging, can you confirm that this will solve the issue?

 

And, as for the using of the Featured Image, as I can see and if I understood the whynopadlock.com description https://www.whynopadlock.com/check.php, the non-secured items are called from http://res-cloudinary(instead of https://res-cloudinary)... which is already an external content? Or, is it not?

 

Thanks,

Vladimir

 

Share this post


Link to post
Share on other sites
Gavin_

Please PM an admin login to me so we can have a look  - thanks

Share this post


Link to post
Share on other sites
vladimirtrajkovic

Hi Gavin,

 

Thanks for the support. I have sent you the link and the credentials via private message on PageLines.

 

Regards,

V

Share this post


Link to post
Share on other sites
Gavin_

Hello 

We logged into your website today. 
We noticed that there was an issue with DMS loading correctly - this was occurring with and without Hover News activated. 

We also noticed that you had a lot of plugins - some of which are probably not needed at all and some which it would be best not to use in a development environment. 
It is possible that the multiple plugins that you are using that do similar things could be causing you with issues. 

We would recommend that you go through the process of identifying what us causing the conflict with DMS - once that is resolved we would then recommend that during development you turn off all caching, gzip and anything this is meant to speed up the site. 

Once this is done - we would be more than happy to look at how Hover News maybe affecting your website. 

Did you clear your cache?
Does it work in a private browser window?
Did you add a plugin recently?
Did you turn off a plugin recently?
Have you fixed file permissions?
Does it work on LocalHost?
Does it occur if you deactivate all other plugins?


 

Share this post


Link to post
Share on other sites
vladimirtrajkovic

Hi,

 

If you could not enter the DMS editor window it is because of Claudflare (I don't know why is Cloudflare causing this issue but it works when I pause it). I will pause Claduflare now, so can you log in again in 5 mins and check whether you could detect the issue.

 

I do not have some other plugins installed recently, and all other plugins work fine.

 

But even if I pause cloudflare I still have the same issue with Hover News.

 

Share this post


Link to post
Share on other sites
vladimirtrajkovic

one more thing: pls make sure that you enter http, not https version of the site

Share this post


Link to post
Share on other sites
Gavin_

We have tried to login to your site again. And we can see that when Hover News is activated the content is pushed to the left. 
However, as you can see from our demo site http://pagelines.kyle-irving.co.uk/hover-news/this is not normal behaviour. 

We also found that when disabling other plugins this had the same effect - i.e shareaholic.  Here is a screenshot with everything activated and no 'skewed to the left issue' - so the problem may not be caused by Hover News. 

http://screencast.com/t/ngC2Gr0jG8mn


Therefore there must be a conflict with another third party plugin that you are using.  We can only recommend that you disable plugins one by one so that the error can be found.

You have so many speed optimisation plugins (which could be causing the conflict) and creates an additional issue for bug finding.

Bug finding when you have multiple caching plugins and speed optimisation tools is very hard - especially as DMS has its own way of handling cache as well. 

Our best advice is for you to create a staging site - do not use any caching or speed optimisation plugins and find out which plugins are not playing nice. 

Share this post


Link to post
Share on other sites
vladimirtrajkovic

One more question - the screenshot you have sent me - is it from the DMS editor window or from live website? Because, in the DMS editor window everything looks fine, but on the live site you can see that the site is pushed to the left.

Share this post


Link to post
Share on other sites
Gavin_

I can't remember but it was probably with the DMS editor on. 

Share this post


Link to post
Share on other sites
vladimirtrajkovic

With DMS editor on it does not shows that the site is moved to the left. You can see the effect only on a live site.

Share this post


Link to post
Share on other sites
Gavin_

Hi

We would truly love to help further, for now though we can only refer to our post above. 

"We have tried to login to your site again. And we can see that when Hover News is activated the content is pushed to the left. 

However, as you can see from our demo site http://pagelines.kyl....uk/hover-news/this is not normal behaviour. 

We also found that when disabling other plugins this had the same effect - i.e shareaholic.  
Therefore there must be a conflict with another third party plugin that you are using.  We can only recommend that you disable plugins one by one so that the error can be found.

You have so many speed optimisation plugins (which could be causing the conflict) and creates an additional issue for bug finding. Bug finding when you have multiple caching plugins and speed optimisation tools is very hard - especially as DMS has its own way of handling cache as well. 

Our best advice is for you to create a staging site - do not use any caching or speed optimisation plugins and find out which plugins are not playing nice. "

Share this post


Link to post
Share on other sites

  • Similar Content

    • vladimirtrajkovic
      By vladimirtrajkovic
      Hi there,
       
      I am planing to use hover news as a showcase of my categories on my category pages on my website. Since I have 10 different categories I will have to create 10 different page templates where I will have to assign each different category on hover news section on each different page.
       
      So my question is whether it is possible to create one page template (where I will have hover news section) which I will assign on 10 different pages. Than somehow I wonder if it is possible that hover news displays category from the page selected. For instance: if a user selects "smartphones" page than hover news section displays posts from "smartphones" category, or if the user select "tablets" page than hover news selection displays posts from "tablets" category.
       
      To make myself more clear I will create 10 pages for 10 categories, I just want to assign one (same) page template for those pages. Basically, what I would like is to save time needed for creating 10 different page templates where I will have 10 different hover news sections to which I will assign 10 different categories.
       
      My website htechnews.com (production version) and here is a test page htechnews.com/smartphones.
       
      Thanks,
      Vladimir
×