Jump to content

Archived

This topic is now archived and is closed to further replies.

Marko

Responsive Grid Spacing

Recommended Posts

Marko

Hi, I have a spacing problem when using the responsive grid. The vertical distance between the lines is much too high.

Responsive-Grid-Spacing-Issue.png

 

I used Firebug to try to figure out how to change this without success. I would appreciate any help.

 

Here's the link to the web page in question: http://3deltastudio.ca/full-studio/

 

Thanks,

Marko 

Share this post


Link to post
Share on other sites
Danny

Hi Marko,

 

Try the following:

 

#pl-nextboxu4vr4wp [class*="span"] {
margin-bottom: 0;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Marko

Hi Danny,

 

Thanks for the suggestion. I added the code to my CSS, but unfortunately it haven't produced any results.

 

In the meantime I further inspected the code in Firebug and finally noticed a piece of code that controls that bottom margin:Responsive-Grid-Issue_Firebug_Scrnsht.pn

 

I tried to change it on the page using:

#page .row [class*="span"] {

margin-bottom: 0;
}
 
but that didn't work. Any ideas on how could I successfully add this to my CSS?
 
Thank you,
Marko

Share this post


Link to post
Share on other sites
Danny

The code did work, but you appear to have changed the PL NextBox for that page and therefore, the ID is no longer the same. So use my code again, but change the ID with the one that is on your page now.

You can find the ID, by opening dev tools and copy the ID from:

 

<Section id="copy whatever is here" ..... >

 

As you can see it is working here - https://cloudup.com/c8N1b7AThQV


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Marko

Hi Danny,

 

I used the code with the proper section ID and it worked! But for some reason it doesn't work when I enter the code in style.css inside pagelines-customize folder, only when it's in Custom LESS/CSS window in DMS interface. Do you know why is that?

 

Thanks for your help.

 

Marko

Share this post


Link to post
Share on other sites
Danny

Marko, either use a child theme or the built-in editor. As far as I am aware we do not support the customize plugin with DMS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Marko

OK, good to know. I wasn't aware that plug-in got phased out. 

 

Thank you.

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×