Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

iBlog customizations

Recommended Posts

sheilahoff

I'm just starting a new site using iBlogPro6 as the child theme. It's located at http://perfect-image.flywheelsites.com/

 

I'm wondering if there's any documentation on the new sections it includes? I'm hitting little tiny questions and hate to keep bothering folks here. For instance:

 

1) iFooter Bottom Credits... is there a way to have it reflect the year of copyright and automatically update it? I usually use Content Copyright which is great but it'd be nice to simplify and just use the Bottom Credits. But I certainly don't want to put a year in and have to manually update it annually! There must be a way. If you leave it blank it automatically fills in the year but also adds Pagelines info! Not good.

 

2) iFooter Breadcrumb icons... Is there any way to add an icon? This client's favicon is a drop of water and that would be ideal there. None of the FontAwseome icons are a water drop.

 

3) iHeader... any way to easily change the colors of the social media icons and/or the nav bar? I imagine I can figure out some CSS for the nav bar but it'd be sweet if there were some built in settings for that.

 

That's what I've got right now. I just started though!

Thanks,

Sheila

 

EDIT: I got the social media icon colors already!

.section-iheader .icons .iheader-link {
    color: #66D0E4;
}

.section-iheader .icons .iheader-link:hover {
    color: #414141;
}

Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Hi Sheila, 

 

1. You add the copyright yourself, via the option field, there is no way to include echo date('Y'); in that field as it doesn't support PHP. Therefore, the only way to do this is to either use a hook or create a child of the section and add the code yourself.

 

2. To do this you will need to use custom CSS.

 

3. Like you mentioned you will need to use custom CSS, if you want to change the colors to something custom.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Thanks Danny. The one question you didn't answer is if there's any documentation for this theme?

 

The client has just informed me he wants the Product navigation to look like what's on this competitor's site...http://www.imageskincare.com/

 

And he wants the nav white on white, no color at all. So now I'm thinking I may have to drop the iHeader entirely and use Business Branding or something else for logo and social media then figure out what menu add-on will do this. If you have a recommendation for that I'm all ears. Thanks.

 

PS...  I just installed UberMenu3 on this site. It integrates with DMS. It even has a spot called Automatic Integration Theme Location where I can designate to use the iBlog iheader section. Perhaps I'm misunderstanding how that should work. Because now I have the bar from iHeader AND the UberMenu. Weird.

 

This plug-in looks great but I’ll need to watch a bunch of videos to learn how to use it. Very complex. Any pointers on how it works with DMS that might speed up the process would be greatly appreciated.

 

PPS...So I’ve sort of given up on getting the iHeader to correctly take the UberMenu though if it could that would be great. I had to keep moving forward. So I tried it with the regular DMS nav bar and navi. I currently have it set with Navi and have moved into trying to make the Home button be an icon. I went into menus and see the little Uber gear. I’ve chosen the icon and save it both in Uber and in WP but I do not get the icon. I’m not sure what I’m missing here. I’ve uploaded a screen capture to show how I have it setup at http://www.hoffmangraphics.com/downloads/home-icon.jpg

 

PROGRESS.... I finally figured out that the home icon wasn't showing because I'd not checked Navi I'd only checked Nav Bar in Uber's settings!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
sheilahoff

And on another note... I can't figure out why the iSlider isn't moving even though I have 6 slides. Are there some settings for it anywhere? Does it work? Do I need to install RevSlider instead?


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

There isn't documentation for the sections, as all sections have inline documentation when required and all other options are self explanatory. I do plan on writing articles most sections that users have trouble with in the near future.

 

Regarding the competitors navigation, firstly I think it is an awful design for a navigation. However, you should be able to achieve something similar with UberMenu. I would place it in the Fixed region or Header region and then place a MediaBox or TextBox above it to add your social networks, contact info etc...

 

iSlider should work out of the box, you don't need to install RevSlider as RevSlider is already installed with all DMS core themes which iBlog is. If the iSlider isn't working, you likely have a script or plugin causing the slider to not function.

 

FYI, can you please refrain from asking multiple questions per topic, our policy is one question per topic. The reason for this is for search indexing reasons. For example, if a user wanted to see my response regarding your question about iSlider, he/she wouldn't be able to locate it, as it is in a topic called iblog customization. Therefore, in future please ask one question per topic.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Thanks Danny. I thought since this was all about nuances of iBlog that it was OK to include here. But I'll start a new thread now for my continuing issues with iSlider.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Yeah I understand your logic, I would do the same myself, but it plays havoc on our search indexing when multiple questions get asked in one topic.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • social_biz
      By social_biz
      I am trying to get iBlogpro6 running under https. All is fine but I am getting a mixed content warning:
      Mixed Content: The page at 'https://s11r.co/' was loaded over HTTPS, but requested an insecure stylesheet 'http://s11r.co/content/uploads/pagelines/compiled-css-core-1464872768.css'. This request has been blocked; the content must be served over HTTPS. The compiled css file are delivered in http not https. I tried toi delete them several times but the error is still there.
      Do I need to fix something in the theme folder? What? Where?
    • rgrptr
      By rgrptr+
      Hi
      I'm in trouble with a site using iBlogPro 6 with the DMS editor. Developers told me to ask support in forums. Here we go…
      I try to make a page with tabs containing a kind of dictionary with some terminology. I am saving and refreshing all the time but the problem is, in some point, the changes aren't saved and I get the three default tabs again as nothing happened. I did it once and again. Then I saw the problem was when I write more than 50.000 characters (or 60.000 counting white spaces).
      What can I do? How do I have to configure server settings? Or is this a theme problem?
      Please I would appreciate any comment about it.
      Thank you very much
    • satronen
      By satronen
      I am currently using Pagelines Framework 2.4.6
      I'm interested to upgrade my site to iBlogPro6
      Will I be able to keep my Pagelines Framework website live and uninterrupted while building my new iBlogPro6 site?
      Is there a online help guide of specifics instructions how to get this process started once I download iBlogPro6?
    • satronen
      By satronen
      I am currently using Pagelines Framework 2.4.6
      I'm interested to upgrade my site to iBlogPro6
      Will I be able to keep my Pagelines Framework website live and uninterrupted while building my new iBlogPro6 site?
      Is there a online help guide of specifics instructions how to get this process started once I download iBlogPro6?
    • webbdo
      By webbdo+
      Hi,
       
      At webbdo.com site I do get validation errors: https://validator.w3.org/check?uri=http%3A%2F%2Fwww.webbdo.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0
       
      - I have disable all plugins. Still same errors.
      - I have not edited any files.
       
      - Only custom code I added is:
       
      .boxed-wrap {   -webkit-box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36);   box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36); }   #site {   background-color: #FAFAFA; } .pl-new-loop .hentry .continue_reading_link {  display: none; }    Why are those errors occurs?  
×