Jump to content

Archived

This topic is now archived and is closed to further replies.

sarahbenoit

After migrating site to a subdirectory, CSS does not display properly

Recommended Posts

sarahbenoit
Framework Version: 2.1.9.1
WordPress Version: 4.01
Plugins in Use: DMS Professional Tools, Pagelines Updater, PLNext Box
Server/Host: GoDaddy
Screenshots:
Details: After migration of site to a subdirectory, the CSS markup is not showing unless logged in to admin on Chrome.
 
How the site looks when signed in to admin - [attachment=2517:logged in.jpg]
 
How the site looks when not signed in - [attachment=2518:logged out.jpg]

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you try the following please, goto DMS Toolbar > Site Settings > Reset and then click on Flush Caches button. Then reload your site and see if this resolves your issue.

 

If that doesn't resolve your issue, can you provide the exact steps you took when migrating your site please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sarahbenoit

Hi Danny,

 

That did not work. When migrating, I followed the following steps as per - http://codex.wordpress.org/Moving_WordPress

 

Here are the step-by-step instructions to move your WordPress site to a new location on the same server:

  1. Create the new location using one of these two options:
    1. If you will be moving your WordPress core files to a new directory, create the new directory.Log in to your site.
  2. Go to the Administration > Settings > General panel.
  3. In the box for WordPress Address (URL): change the address to the new location of your main WordPress core files.
  4. In the box for Site Address (URL): change the address to the new location, which should match the WordPress (your public site) address.
  5. Click Save Changes.
  6. (Do not try to open/view your site now!)
  7. Move your WordPress core files to the new location. This includes the files found within the original directory, such ashttp://example.com/wordpress, and all the sub-directories, to the new location.
  8. Now, try to open your site by going to yourdomain.com/wp-admin. Note, you may need to go to yourdomain.com/wp-login.php
  9. If you are using Permalinks, go to the Administration > Settings > Permalinks panel and update your Permalink structure to your.htaccess file, which should be in the same directory as the main index.php file.
  10. Existing image/media links uploaded media will refer to the old folder and must be updated with the new location. You can do this with the Velvet Blues Update URLs plugin, or with a search and replace tool, or manually in your SQL database.
  11. In some cases your permissions may have changed, depending on your ISP. Watch for any files with "0000" permissions and change them back to "0644".
  12. If your theme supports menus, links to your home page may still have the old subdirectory embedded in them. Go to Appearance::Menus and update them.

Share this post


Link to post
Share on other sites
Danny

Can you try the following please.

 

Go to WordPress Admin Dashboard > PageLines and click the Save LESS button. Then reload your homepage and see if this resolves your issue.

If that doesn't resolve the problem, if you have added any custom CSS or LESS CSS, please remove everything and then save. Go back to your homepage with no custom CSS/LESS added and then see if the problem persists. If it doesn't then the likely hood is that you have some CSS or LESS CSS that isn't valid and therefore, causing the issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sarahbenoit

Hi Danny,

 

I did as instructed. First I went and clicked the Save LESS button and then later returned and removed all custom CSS, yet the problem still persists.

 

 

Share this post


Link to post
Share on other sites
Danny

Can you send me a PM with the following info please:

 

1. A link to this topic so I know what it is referring.

2. A link to the site in question

3. Your admin username/password

4. Make sure all plugins are disabled

5. Make sure DMS debug mode is active (WordPress Admin Dashboard > PageLines, last option).

 

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Have you made any changes to the core files at all ?

 

Because what is happening is rather odd, your compiled CSS files are giving a 404 when you're not logged in. You have no plugins active, your URLs all look correct, so the only thing I can think of is that your server is configured oddly.

 

I will speak to one of our developers and see what they suggest.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Can you PM me again and this time provide your FTP details so our developer can login and take a closer look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • social_biz
      By social_biz
      I am trying to get iBlogpro6 running under https. All is fine but I am getting a mixed content warning:
      Mixed Content: The page at 'https://s11r.co/' was loaded over HTTPS, but requested an insecure stylesheet 'http://s11r.co/content/uploads/pagelines/compiled-css-core-1464872768.css'. This request has been blocked; the content must be served over HTTPS. The compiled css file are delivered in http not https. I tried toi delete them several times but the error is still there.
      Do I need to fix something in the theme folder? What? Where?
    • rgrptr
      By rgrptr+
      Hi
      I'm in trouble with a site using iBlogPro 6 with the DMS editor. Developers told me to ask support in forums. Here we go…
      I try to make a page with tabs containing a kind of dictionary with some terminology. I am saving and refreshing all the time but the problem is, in some point, the changes aren't saved and I get the three default tabs again as nothing happened. I did it once and again. Then I saw the problem was when I write more than 50.000 characters (or 60.000 counting white spaces).
      What can I do? How do I have to configure server settings? Or is this a theme problem?
      Please I would appreciate any comment about it.
      Thank you very much
    • satronen
      By satronen
      I am currently using Pagelines Framework 2.4.6
      I'm interested to upgrade my site to iBlogPro6
      Will I be able to keep my Pagelines Framework website live and uninterrupted while building my new iBlogPro6 site?
      Is there a online help guide of specifics instructions how to get this process started once I download iBlogPro6?
    • satronen
      By satronen
      I am currently using Pagelines Framework 2.4.6
      I'm interested to upgrade my site to iBlogPro6
      Will I be able to keep my Pagelines Framework website live and uninterrupted while building my new iBlogPro6 site?
      Is there a online help guide of specifics instructions how to get this process started once I download iBlogPro6?
    • webbdo
      By webbdo+
      Hi,
       
      At webbdo.com site I do get validation errors: https://validator.w3.org/check?uri=http%3A%2F%2Fwww.webbdo.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0
       
      - I have disable all plugins. Still same errors.
      - I have not edited any files.
       
      - Only custom code I added is:
       
      .boxed-wrap {   -webkit-box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36);   box-shadow: 0px -60px 28px -5px rgba(0,0,0,0.36); }   #site {   background-color: #FAFAFA; } .pl-new-loop .hentry .continue_reading_link {  display: none; }    Why are those errors occurs?  
×