Jump to content

Archived

This topic is now archived and is closed to further replies.

swiftitnz

CSS for menu li item padding customization

Recommended Posts

swiftitnz

Hello Danny and the rest of the brilliant people out here!

 

I'm trying to figure out what I have been doing wrong here customizing the padding for this Menu on the top right? (See Image below).

 

Saw this thread (http://forum.pagelines.com/topic/37419-margin-being-added-to-div-in-the-textbox/) and tried creating custom css class but didn't work.

 

The demo site I'm working on link is: http://demojobboard.swiftitsolutionz.com/

 

Please suggest.

 

Regards,

 

Imran

 

2a8866c9_o.jpeg

Share this post


Link to post
Share on other sites
jmad

Are you just wanting to move the blue nav bar text to the right?  Try

 

.navbar-content-pad.fix {

float: right;

}

 

 

Share this post


Link to post
Share on other sites
swiftitnz

jmad Thanks for your reply.

 

Actually I am looking to customize the elements shown in the picture below (belonging to the Nav menu on top-right corner), where it says 'Login and Register'.

 

Basically trying to make the padding: 5px 12px;. But not sure how to put that in DMS custom css section !!

 

Thanks again for your help.

 

a61fe720_o.jpeg

Share this post


Link to post
Share on other sites
Danny

HI,

 

Well you can't use your custom class, as you have added it to the TextBox and not the Nav section, so that won't work.

 

However, if you add that class to the NavBar section and then use the custom CSS, it should resolve your issue:

 

#site .topslogun .navbar .navline > li > a {
  padding: 5px 12px;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
swiftitnz

Awesome. Done. Thanks for your help Danny.

 

 

 

HI,

 

Well you can't use your custom class, as you have added it to the TextBox and not the Nav section, so that won't work.

 

However, if you add that class to the NavBar section and then use the custom CSS, it should resolve your issue:

 

#site .topslogun .navbar .navline > li > a {
  padding: 5px 12px;
}

 

 

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
×