Jump to content

Archived

This topic is now archived and is closed to further replies.

dgsarnow

Margin being added to div in the textbox

Recommended Posts

dgsarnow

I need to be able to change the margin-bottom setting .pl-section-pad for a textbox inside a two-column section.

 

I created a custom class for the column named "callus".

 

In the custom CSS area I created the following:

 

.callus div.pl-section-pad {margin-bottom: 0; padding:0;}

 

When I inspect the section using Chrome, I still have margin-bottom:1em and padding:8px.

 

I do not want to have .pl-section-pad changed globally just for the one area.

 

You can see the site at http://harqen-david.pagelines.net/

 

Thanks,

 

Dave


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
dgsarnow

It looks like this is being overwritten by this line from the Pagelines core css. Any idea how to override this for just this section?

 

body .pl-area .pl-section .pl-section > .pl-section-pad


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
Danny

Hi Dave,

 

If you're referring to the red bar at the top of your site, you seem to have resolved your issue. However, you shouldn't use the !important declaration as it is bad practice and can potentially cause issues in the future with other css you may add.

 

So what you will want to do is add a custom class like you have added to the textbox. So remove the callus class from the canvas and add it to the textbox itself. Then use some CSS like this:

 

#site .callus .pl-section-pad {
  margin-bottom: 0;
  padding: 0;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dgsarnow

Danny,

 

Thanks so much! Can you tell me when I should use the !important and when I should not? I am also unclear where to put the cutsom class. Should I always put it at the item itself or the canvas container?

 

Thank you again!

 

Dave


WordPress 4.1.1

DMS2 2.1.9.3 running Skeleton Basic Child Theme

Share this post


Link to post
Share on other sites
Danny

The only time you should use it is if something has inline styling or you can't override a default style. In regards to the custom class, add it to both your textbox sections styling classes field.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
×