Jump to content

Archived

This topic is now archived and is closed to further replies.

jharri74

Changed URL now fonts and front editor screwed up

Recommended Posts

jharri74

Hello,

 

Like a lot of people, I have built my wordpress (version 4) website in it's own folder. Not the top level of the hosting server.

 

The domain was still pointing to the old website also in it's own folder. While i was building the the new website, the IP address/folder(http://s446863904.onlinehome.us/WP) was pointing to the website i was building. I eventually pointed the domain (http://envymeremy.com) here.

 

Thats when things got a little screwed up. Especially when I made the change in wordpress general settings.

 

WordPress Address (URL): http://s446863904.onlinehome.us/WP

Site Address (URL): http://envymeremy.com(formerly the same as above)

 

So after fixing the 505 and 404 issues (editing the .htaccess file in top level of this website) that now follow changing the url, the first thing i noticed was that the fonts weren't embedding.

 

In my child theme's css file, i had to change:

 

@import url("../dms/style.css");
@import url("fonts/stylesheet.css");

 

TO:

 

@import url("../dms/style.css");
@import url('http://envymeremy.com/wp-content/themes/jayharry_theme-child/fonts/stylesheet.css');

 

The pagelines font/symbols  for dropdown and slider arrows aren't loading.

Screen-Shot-2014-11-16-at-7.53.26-AM.png

 

So now whats happening is, when I launch the dms editor, it goes to a page that "does not exist". I'm thinking thats because the homepage was http://s446863904.onlinehome.us/WPand is now http://envymeremy.com/.

 

When i click on the links in the navigation (Home, about us, etc), it takes me to the page, but I don't get the dms editor with options to add anything, edit the sections or anything. Just the page as i would see it if i were not logged into wordpress.

 

I'm using:

wordpress 4

DMS 2 with a child theme

hosting: 1and1.com plan: 1&1 Unlimited

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Danny

HI,

 

I am not following your issue, as far as I can tell both of them are different domains using different IPs. Therefore, you can not change the WordPress URL to use a different domain as far as I am aware. The files must be on the same server. I recommend you view the WordPress docs - http://codex.wordpress.org/Changing_The_Site_URL

If you view your sites page source, the files are still loading from the other domain - https://cloudup.com/cOVHuYg8RfX


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jharri74

Apogolies for not being clear enough.

 

With 1&1 hosting, If you don't have a domain name, you can use their default one as the domain. In this case, http://s446863904.onlinehome.us which points to the top level of the directory in the hosting plan. In this directory i created a folder named WP. This is were I have built the website. The domain www.envymeremy.com was originally pointed to http://s446863904.onlinehome.us/site and I later pointed it to http://s446863904.onlinehome.us/WP ( the current website). This is when the issues started. I would image since everything is in the same hosting plan, it's all on the same server.

 

 

 

 

Share this post


Link to post
Share on other sites
Danny

Not sure how 1&1 is setup so I can't say if they're on the same server. However, to resolve your issue, you're going to need to change the URL in your database. As at the moment they're all pointing to the other domain.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jharri74

Scratch that! Fonts are now working. I think the cache had to be reloaded but I am good now. thanks for you time.

 

 

Share this post


Link to post
Share on other sites
Danny

Awesome and thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Kedark
      By Kedark+
      Hello, I need help. Can and how to do it. I need to add more page appearance templates (page attributes). At the moment it's default and FRAMEWORK A, FRAMEWORK B etc. I need to add two more. How can I do this.
      Unfortunately, I did not find such a thread on the forum.
      Regards
      Radoslaw
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • MiraAdmin
      By MiraAdmin+
      Looking for some help on a recently developed issue. Editor will not load. 
      Theme:  DMS2
      Error from:  Chrome - Inspector - console view
      Error message: Refused to execute script from 'http://xxxx.xxx/wp-content/themes/dms/dms/editor/js/gettext.js/?ver=4.9.7' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
      Occurs on all sites on same server. 
      WP versions to 4.9.5, 4.9.6, 4.9.7 = same behavior. Worked properly on these same versions until 07/04/2018.
      No new plugins. Isolating plugins offers same behavior. 
      Server vendor reports no changes, patches, etc. 
      Server re-starts no impact.  

      Thank you. 
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
×