Jump to content

Archived

This topic is now archived and is closed to further replies.

margie

how do I move text in mediabox from below to one side or another

Recommended Posts

margie

Hi-

 

Is there a way to move the text from under the mediabox image to display on either the right or left side of the image?  Thanks so much. 

Share this post


Link to post
Share on other sites
Danny

You could also just use the Hero section which has options for uploading an image and positioning text to the left or right of the image. However, the text will be larger due to the sections styling.

You could also use basic HTML with the PageLines Grid inside a MediaBox and position your image and text that way. For example:

 

Text on left, Image on right.

 
 
<div class="row">
  <div class="span6">
    <h1>Header goes here...</h1>
    <p>Text goes here...</p>
  </div>
  <div class="span6">
    <img src="Image path/URL" alt="">
  </div>
</div>
 
 
Image on left, Text on right
 
<div class="row">
  <div class="span6">
    <img src="Image path/URL" alt="">
  </div>
  <div class="span6">
    <h1>Header goes here...</h1>
    <p>Text goes here...</p>
  </div>
</div>

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
margie

HELP!  I inserted the code above and it worked fine for a few minutes but now all my media boxes on that page are gone!  When I go to try and add a media box to the page, it won't let me edit the media box (via the pencil icon) or increase or decrease the width!  How do I undo the above?

 

Any assistance at this point would be very beneficial and potentially save my job.  Thank you so much.

Share this post


Link to post
Share on other sites
margie

Sorry to bother you again but now I can't even delete the boxes. 

Share this post


Link to post
Share on other sites
margie

disregard...the problems went away...still had to recreate my media and text boxes but all else is working like normal again

 

Share this post


Link to post
Share on other sites
Danny

Do you have a cache plugin installed ?

Also, if you're not comfortable with HTML, then I recommend you use James method. As when I tested the code before adding it, I had multiple mediaboxes on my page and when I added that code, I didn't encounter any issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
margie

Thanks, Danny.  Sorry for the panic yesterday.  To answer your question, no I don't have a cache plug-in installed.  Could this have been causing the issue?

Share this post


Link to post
Share on other sites
Danny

Well its rather an odd issue you experienced as I tend to use the MediaBox more than any other section and I am always placing HTML inside the section and have not once encounter the issue you experienced.

Therefore, the only thing I can think could cause the issue was a plugin or script conflict. I have tested the code several other times and still not received any issue with my other MediaBoxes.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • triggerfish
      By triggerfish+
      Media Box not taking Google Maps input
      I have the EMBED MAP code from Google (which I have done 100''s of times before),
      I input it into the TEXTBOX or MEDIABOX SAVE it, and as soon as I refresh the page the text is gone (and of course there is no map).
      I have rebooted, refresh cache, everything with no luck..it just will not take the google maps input...it will however take and save a simple text input.
      I am using WordPress 4.5.1
      DMSVersion: 2.2.1.1
      The google code is:
      <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2602.466376170749!2d-123.11645494869879!3d49.286507879230314!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x548671828dbf1c61%3A0x489cbb919c49d6e!2s325+Howe+St%2C+Vancouver%2C+BC+V6C+3N2!5e0!3m2!1sen!2sca!4v1461869255884" width="800" height="600" frameborder="0" style="border:0" allowfullscreen></iframe>
      The website and CONTACT PAGE ( the map is next to the CONTACT VALRI text, there is a textbox and media box there) are here:
      http://valufitness.com/contact-us/
      Your login is:
      http://valufitness.com/val-login/
      USer= ***
      pass= ****
       
    • amb62137
      By amb62137
      Hi there,
      I am trying to change an image on hover using either MediaBox or TextBox. The image is manually inserted using the HTML box. 
    • pagelines_45
      By pagelines_45
      I am trying to remove the bottom padding from a media box.  When I inspect and change the value it works but I can not for the right css section names to change it in either the page css or custom code area.  I have even tried custom style for the page, but no luck.  Here is the site http://wordpress.howard-boats.com/  on the home page I am trying to get the wide sailboat image to touch the foot.  bottom-padding:0px  but I cant get it to work.  Thank you for your help I'm sure I am doing something stupid.
       
      David
       
    • dgsarnow
      By dgsarnow+
      I am really enjoying using Pagelines. One of the things that I find myself doing a lot is creating two column widths with an image on one side and text on the other. It is often really hard to get these things to look balanced with each other. Either the image is big and the text just hangs there or the text is.
       
      it would be great to have the option when using two columns or the Hero section to choose whether to align the content tops, bottoms, or along their vertical middles. I know you can do this with Mediabox and min-height, but then you are potentially left with a lot of extra space when the columns collapse in responsive mobile view.
       
      Just a thought.
    • todd@kitetails.org
      By todd@kitetails.org
      HI -   I've been having problems with MediaBox cropping a Youtube video I am trying to embed.   Regardless of the size of the video, the bottom is cropped out. This is also regardless of the "Disable Media Vertical Centering" function and "MediaBox Min Height" settings in MediaBox.   I've been using the "Text and Embed HTML" box to embed the video, using a Pagelines shortcode, [pl_video type="youtube" id="KxJlJ7NbYLY"]   Any possible ideas as to where I am going wrong?   Thanks in advance for the assist!   Todd
×