Jump to content

Archived

This topic is now archived and is closed to further replies.

Claude203

Possible to Have Conditional CSS Based On Presence of Image or Not?

Recommended Posts

Claude203

I have been searching for a solution on this but I'm not sure if it is possible but I'll ask anyway. I would like to format the margins of the post excerpts in the .article-wrap and in the .clip-box but this will vary depending on whether or not there is a featured image attached to the post. Is there a way to produce conditional results through CSS? 

 

Thank you!


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Not sure what you mean, as there is no margin applied to the .article-wrap class ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Claude203

Danny, I wanted to move the excerpt over to the left, so I added this:

 

.post-excerpt {
margin: 0 0 0 -88px;
}
 
.clip_box .continue_reading_link {
margin: 0 0 0 -88px; 
}
 
But for posts with no image, it moves the excerpt too far over. 
 
Here is an example of the inconsistency:
 
 
Thank you.
 
 

Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Claude203

Does that clarify the situation? Thanks.


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Danny

Yeah I see your dilemma, the only thing I can suggest is you attempt to use LESS, see this as a potential solution and also the LESS documentation.

 

http://stackoverflow.com/questions/14910667/how-to-use-if-statements-in-less

 

Please be aware that this isn't something we can provide support for, as the issue isn't with DMS, but how you want conditional styling on elements that have/do not have an image.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Kedark
      By Kedark+
      Hello,
      I apologize for the trivial question, but I can not deal with it. How do I turn off the display of a distinctive image on the page? (I have to add it because I use plugins that use it), but as I display the page, I do not want it to be visible (and appears above the subject.).
      Probably a cliché but I can not deal with it. Therefore, a request for help.
      Regards
      RKA
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • mtaus
      By mtaus+
      I have added a Lax section on the footer of this site: http://www.ics-law.org.php72-38.lan3-1.websitetestlink.com/ but the background image is not displaying. When I first add the image it appears in the background, but then after saving and reloading it is gone even though the thumbnail indicates it's still there. Screenshot attached.
      Any suggestions?

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
×