Jump to content

Archived

This topic is now archived and is closed to further replies.

Frederic

short code issue

Recommended Posts

Frederic

Hi there,

 

1. I have just updated to DMS 2 and have a little problem with a shortcode:

 

[pl_label type="warning"]<a href="http://seeduni.com/"><span style="font-size: 15px;">BLOG</span></a>[/pl_label]

 

It was turning as a beautiful yellow on DMS 1   here

 

But for some reason it is now turning red on DMS 2 here

 

The other pl_label types are working ok, just the "warning" doesn't seem to want to do its job.

 

Many thanks for advising.

Share this post


Link to post
Share on other sites
batman

HI Frederic

Always the "warning" was orange.

http://screencast.com/t/uynHrLn7yHYp

If you need to change  the color, you can add CSS rules.

 


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The shortcode is now an orange color in DMS 2.x, if you want a Yellow style button, simply add your own styling.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Frederic

Thanks,

 

Would you be able to help me do that? I have seen this tutorial in the docs 

 

http://support.pagelines.me/docs/customization/create-custom-buttons/

 

But it doesn't tell me how to do the same for labels.

 

Do i just need to insert

 

 

.btn-purple {

color: @yelllow;

}

 

replacing .btn with the corresponding code for labels (which i do not know)?

 

 

Thanks

Share this post


Link to post
Share on other sites
Danny

Just follow the instructions on that guide, thats all I did, then added the following the to my custom CSS/LESS:

 

.btn-yellow {
  color: white !important;  
  .buttonBackground(lighten(@yellow, 10%),@yellow);
  text-shadow: 0 -1px 0 rgba(0,0,0,.25);
 
  &:hover {
    text-shadow: 0 -1px 0 rgba(0,0,0,.25);
    color: white;
  }
  &:active {
    text-shadow: 0 -1px 0 rgba(0,0,0,.25);
  }
}
 
This then gives me a yellow-ish colored button when I use it in the following HTML:
 
<a class="btn btn-large btn-yellow" href="#">Yellow Button!</a>
 
Please be aware that you will not be able to select this colored button from sections that include a drop down for buttons. If you want to use this color in a section that has options for buttons. You will need to edit that section and add the option yourself, you can do this by creating a child of that section.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Frederic

Thanks a lot Danny,

 

But what do I need to use instead of .btn  for a label because i need a label, not a button.

 

Thanks!

 

Share this post


Link to post
Share on other sites
Danny

Replace the code with this:

 

.label-yellow, .badge-yellow {
  background-color: @yellow;
  color: @white;
}
 

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Frederic

Hi Danny,

 

Thanks for your reply -

 

inserted

 

 

.label-warning, .badge-warning {
  background-color: #ffc40d;
  color: @white;
}
 
works!
 
Thanks

Share this post


Link to post
Share on other sites
Danny

No problem.

I am going to create a new bundle version of Skeleton, which will have lots of different color variations of buttons, labels and badges.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Frederic

Thanks Danny but it's not 

 

.label-yellow, .badge-yellow 

 

it is

 

.label-warning, .badge-warning

Share this post


Link to post
Share on other sites
Danny

Not sure what you mean by your post above, I tested the code before posting and have no issue using it to create a yellow label ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×