Jump to content

Archived

This topic is now archived and is closed to further replies.

mnehmer

Main Nav - Keep Parent Link Active

Recommended Posts

mnehmer

I have added a drop down navigation menu to my site. My Menu appear as Company > About Us. When I load the About Us page, I'm trying to keep the parent link "Company" with the active link color.  When I select the child page of About Us, the Company link does not stay active. Here is the code I'm using:

 

.current-menu-ancestor {

  color: #C0382A;
}
 
 How can we fix this?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you provide a link to the site in question, so we can see which navigation section you're using please. As the Navi section should have this styling already built in.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
mnehmer

Hi Danny, 

 

The site is located at: http://kairys.covvo.com/.  We are using the NavBar, however I originally started with Navi but the mobile menu was not displaying.   With NavBar the mobile menu displays, but I'm not able to get the parent link to stay active.   

 

Share this post


Link to post
Share on other sites
Danny

Try the following:

 

#site .section-navbar .navbar.pl-color-base .navline > li.current-menu-ancestor > a {
color: #C0382A;
}
 
 

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×